Join us for an upcoming Shopify Partner webinar on February 27, 2024. Discover the latest Checkout Extensibility features, and deep dive on improvements to Shopify Functions and Web Pixels. Register now for either the 10am EST or 2pm EST sessions.
Solved

Trouble upgrading from Craft v11 to Craft v12

HH2023
Tourist
3 1 0

When trying to add Craft v12 to my library, it just spins and spins and never adds the updated theme. I chatted with support a few weeks back, and they rebooted the server I'm on to make sure there aren't caching issues. That didn't help. I've only made a couple of very small edits directly to code and I suspect that one or more of them is causing the failure... maybe? Has anyone else had trouble and figured this out? I really don't want to have to install a clean v12 and reconfigure the entire shop, which could take an entire day... unless there's a shortcut that someone knows (ie. just copy the contents of these files from the old theme to the new one).

 

HH2023_0-1705602177165.png

 

Accepted Solution (1)
HH2023
Tourist
3 1 0

This is an accepted solution.

No. Support staff helped me identify the files that were causing the failure. Once I removed two unneeded files, the upgrade worked.

 

The files were added by a basic customization function (adding a new metaobject template) , so I'm not sure why they would cause an issue. I wasn't using those templates (just testing something) so no harm in removing them. It's possible that something in those metaobjects changed causing the templates to be corrupted. Not sure, but I'm all set now.

 

Thanks for checking in. Ok to close this thread.

View solution in original post

Replies 3 (3)

Liam
Shopify Staff
2677 288 734

Hi - are you still seeing this issue?

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

HH2023
Tourist
3 1 0

This is an accepted solution.

No. Support staff helped me identify the files that were causing the failure. Once I removed two unneeded files, the upgrade worked.

 

The files were added by a basic customization function (adding a new metaobject template) , so I'm not sure why they would cause an issue. I wasn't using those templates (just testing something) so no harm in removing them. It's possible that something in those metaobjects changed causing the templates to be corrupted. Not sure, but I'm all set now.

 

Thanks for checking in. Ok to close this thread.

Liam
Shopify Staff
2677 288 734

That does sound like an unusual issue - but I'm glad it's working as expected now 🙂 

Liam | Developer Advocate @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog