FROM CACHE - en_header

Additional Checkout Methods inconsistent

Don9
Shopify Partner
12 0 6

Good day,

 

We were contacted by a customer who has been using Apple Pay regularly on our site. Customer stated that Apple Pay is no longer visible as an "Additional Checkout Method" in the Cart.

 

First of all,  we have made NO payment-related changes to our settings. All of the following have been activated for months (or years):

  • Apple Pay
  • Google Pay
  • PayPal Express Checkout
  • Meta Pay
  • Shop Pay

 

While testing today, I discovered the following number of additional checkout methods shown in the cart:

  • Desktop Safari: 0
  • Desktop Chrome: 4
  • Desktop Firefox: 3
  • Mobile Safari: 0
  • Mobile Chrome: 0

 

We do understand that Apple Pay will only show up on Apple devices and browsers, and that other methods are also conditional based on the existence of accounts, etc.

 

However, during previous testing, we consistently saw several methods displayed in every browser.

 

Has anyone else experienced inconsistent display of these express checkout services? Might this be a temporary server-related glitch, or are there settings that could be preventing a more consistent display of payment methods?

 

Screen Shot 2022-09-24 at 1.35.13 PM.pngScreen Shot 2022-09-24 at 1.35.05 PM.pngScreen Shot 2022-09-24 at 1.34.56 PM.png

Reply 1 (1)
herren
New Member
1 0 0

Hi Don9,

 

I began experiencing an issue with Express Checkout (EC) not appearing while using Safari within the past two weeks. It is exactly as you described, EC appears on Desktop Chrome & Desktop Firefox but not Desktop Safari. I tried using 3 different Macs and two different iPhones with the same results.

 

Note: I'm a customer of a store, not a store owner. I've regularly used Apple Pay on this store for almost two years. 

 

Around 1 hour ago I made a purchase from said store and did not have EC options. During the course of writing this message, I tried again and now the EC options are appearing as normal. This problem was affecting multiple devices and now appears to have resolved itself. I don't know what to say.

 

I know this isn't very helpful, but have your customer try again and see if the EC options are showing up now.