Why isn't calculated shipping working on my order?

Shopify Partner
43 0 2

I set up shipping for my order and the flat rate works fine but calculated does not. I get this errors.

Shipping not available

Your order cannot be shipped to the selected address. Review your address to ensure it's correct and try again, or select a different address.
If I change to flat rate it works.
My product has  a weight in OZ
I set up shipping


I have a default packing




What could I be missing?
Replies 4 (4)

Shopify Partner
482 51 81

Carrier-calculated rates are highly effective for obtaining accurate rates at checkout without the need to configure a Rate Card or complex rates based on zone, weight slab, etc. However, the initial setup requires assistance.


Below are a few possibilities to consider if it doesn't work. You may reach out to Shopify support for help:


1. The address may be incorrect. The postal code must be a 5-digit postcode. A flat rate does not require a complete address to be valid, but live rates do.
2. The address could be in a location where USPS does not operate.
3. The services that have been enabled may not be suitable for shipping the specific item. For example, the weight limit for USPS First-Class Mail packages is 15.99 ounces (or just under 1 pound) for commercial rates and 13 ounces for retail rates.


You may also verify the exact 'from', 'to', and package details on the USPS website to check serviceability.

Co-Founder / CEO @ PluginHive
Shipping Automation | FedEx shipping | Multi-carrier shipping | Shipment Tracking | Australia Post shipping
Shopify Partner
43 0 2

I ship this sort of thing all the time with USPS.

but to reply:

1. It's my address, I know its complete.

2. They ship items to me daily

3.  I bought  a 1 ounce item. its configure in my product as 1 ounce.
4. If I use the same info from USPS it works ok, or at lease will allow me to purchase a label.

Shopify Partner
43 0 2

Also tried a few address from google that are companies. I tried a few address from the auto complete, and a few other I had in my DB. If it really is an address issue, can someone supply an d address that works as a test? I have no faith that that is the issue but want to rule it out.


If those are al that can make it fail it must be "The services that have been enabled may not be suitable for shipping the specific item." but I do not see anything in the item that would not make it ship-able.



Shopify Partner
43 0 2

Solved it, you need to set up a location



There is also a address under the business setup but that is not the one to use. I found this by clicking local delivery, it told me I had no location set up. Please add this to the troubleshooting steps!