admin fulfillment post failing on three orders out of thousands

tjohnson1
New Member
3 0 0

Hello.  We have an Azure Logic App that gets Ship Confirmations from our WMS and updates Shopify through the Admin/Fulfillment API.  It was working for months with no errors and then recently, three orders failed.   I see nothing wrong with the data being sent.  The information for the last order is below.  I was able to fulfill the first two orders through the online Shopify Store pages and add the tracking information.  I haven't done that. yet, for the order below. 

Can someone look at why this call is failing for this order?

Call information:

{
    "method""POST",
    "headers": {
        "Authorization""*sanitized*"
    },
    "body": {
        "fulfillment": {
            "location_id"64388956337,
            "notify_customer"true,
            "tracking_company""FedEx",
            "tracking_numbers": [
                "61290274409630040897"
            ]
        }
    }
}

 

Response:

{
    "statusCode"422,
    "headers": {
        "Transfer-Encoding""chunked",
        "Connection""keep-alive",
        "X-Sorting-Hat-PodId""176",
        "X-Sorting-Hat-ShopId""10802380",
        "Referrer-Policy""origin-when-cross-origin",
        "X-Frame-Options""DENY",
        "X-ShopId""10802380",
        "X-ShardId""176",
        "X-Stats-UserId""",
        "X-Stats-ApiClientId""4899137",
        "X-Stats-ApiPermissionId""308128612529",
        "X-Shopify-API-Terms""By accessing or using the Shopify API you agree to the Shopify API License and Terms of Use at https://www.shopify.com/legal/api-terms",
        "HTTP_X_SHOPIFY_SHOP_API_CALL_LIMIT""1/80",
        "X-Shopify-Shop-Api-Call-Limit""1/80",
        "X-Shopify-API-Version""2021-01",
        "Strict-Transport-Security""max-age=7889238",
        "X-Shopify-Stage""production",
        "Content-Security-Policy""default-src 'self' data: blob: 'unsafe-inline' 'unsafe-eval' https://* shopify-pos://*; block-all-mixed-content; child-src 'self' https://* shopify-pos://*; connect-src 'self' wss://* https://*; frame-ancestors 'none'; img-src 'self' data: blob: https:; script-src https://cdn.shopify.com https://cdn.shopifycdn.net https://checkout.shopifycs.com https://api.stripe.com https://mpsnare.iesnare.com https://appcenter.intuit.com https://www.paypal.com https://js.braintreegateway.com https://c.paypal.com https://maps.googleapis.com https://www.google-analytics.com https://v.shopify.com https://widget.intercom.io https://js.intercomcdn.com 'self' 'unsafe-inline' 'unsafe-eval'; upgrade-insecure-requests; report-uri /csp-report?source%5Baction%5D=create&source%5Bapp%5D=Shopify&source%5Bcontroller%5D=admin%2Forders%2Ffulfillments&source%5Bsection%5D=admin_api&source%5Buuid%5D=fec3ba23-ad9f-4f5d-9447-9c0f0c7151cf",
        "X-Content-Type-Options""nosniff",
        "X-Download-Options""noopen",
        "X-Permitted-Cross-Domain-Policies""none",
        "X-XSS-Protection""1; mode=block; report=/xss-report?source%5Baction%5D=create&source%5Bapp%5D=Shopify&source%5Bcontroller%5D=admin%2Forders%2Ffulfillments&source%5Bsection%5D=admin_api&source%5Buuid%5D=fec3ba23-ad9f-4f5d-9447-9c0f0c7151cf",
        "X-Dc""gcp-us-central1,gcp-us-central1,gcp-us-central1",
        "X-Request-ID""fec3ba23-ad9f-4f5d-9447-9c0f0c7151cf",
        "CF-Cache-Status""DYNAMIC",
        "Expect-CT""max-age=604800, report-uri=\"https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct\"",
        "CF-RAY""691d8c6db834270f-DEN",
        "alt-svc""h3=\":443\"; ma=86400, h3-29=\":443\"; ma=86400, h3-28=\":443\"; ma=86400, h3-27=\":443\"; ma=86400",
        "Date""Mon, 20 Sep 2021 19:44:28 GMT",
        "Server""cloudflare",
        "Content-Type""application/json; charset=utf-8",
        "Content-Length""59"
    },
    "body": {
        "errors": {
            "base": [
                "An error occurred, please try again"
            ]
        }
    }
}
0 Likes
tjohnson1
New Member
3 0 0

Hello I had one more order like this happen again.  One thing common, is when I view these from the Shopify Store, I see the line items in two separate groups.  One group will have line items marked as subscription and the group don't have any items marked as subscription.  I believe when an order is one or the other everything works, but when it has both it fails.  Can someone from Shopify please look into it?

 

X-Request_ID c6307b3d-98b0-45f2-b49e-d50ca39017a5

 

Screenshot 2021-09-29 161844.png

0 Likes