App Installation failing and cannot retry installation on the developer store.

rushi-kamble
New Member
1 0 0

I am very new to Shopify app development and have stumbled upon an issue,

Initially I created an app inside our partners portal with the new payments extension enabled and granted set permissions, with the payments extensions URL [Session, Void, Capture] and app URL routed by ngrok to local setup.
I tried to install the app inside the development store with the option "Test on Development Store" from the app, 

I selected the development store which was needed and clicked on "Install app" option.
Once it shown me this page which is the installation page, which stated the "Install unlisted app" and I clicked on that button.

Now as per our mechanism it should have routed to some of our internal page but it did not happen and the page that popped up was as follows ->

Screenshot 2021-11-01 at 12.27.14 PM.png

After which I cannot retry installation or anything as the same page comes whenever I retry.
The major things I noticed -

  1. After the installation failed the app is said to be installed on the development store, and the count of installs increased for the app.
  2. There is shown an app installed for the store when traversed from the partners portal and clicked on the store which install happened. As shown in below image ->
    Screenshot 2021-11-01 at 12.41.43 PM.png
  3. The app is not there in the installed list inside the store account page under the options "apps" nor its inside the "Third party payments" option in the settings->payments page. Please refer following image as it highlights that no app is installed for this store.
    Screenshot 2021-11-01 at 12.45.09 PM.png

  4. Now I cannot uninstall the app from anywhere also cannot also install it to the same app as it shows me error as the "There is no page to this address".

The configurations changes I made regarding the app which has payment extensions ->

  • The name of the app was all capital letter before installation process started for example - "Demo-Test-Payments".
  • As the installation failed, I searched in the developers community and also talked with Shopify support, which lead me to this one post POST LINK  which stated to that capital letters can be also be effecting the installation. Hence I changed the name to small letters like - "demo-test-payments", but still faced same issue.

I tried various scenarios like installing on different stores but the outcome was the same. Now atlast I created one more app and tried to install that which happened flawlessly but the one I want to use and is the main app which I need to function is not working correctly for me. Please help me out and let me know if anyone has some solutions for this.


Thanks alot in advance

 

Replies 0 (0)