AWS EventBridge integration - Address is invalid

1point619
New Member
2 0 0

Hey everyone,

For the past few days I've been trying to figure out how to send my hooks to EvventBridge without any success. My client is on my neck and i'm getting frustrated. Initially, I had tried using the graphiql app to subscribe to a webhook but all i got was an error Address is an AWS ARN and includes api_client_id '5*****5' instead of '2315872'"

After digging around some more I came upon this thread: EventBridge Integration is broken which basically says I should be subscribing from within my own app. I've done this but still get the same error. Anyone, someone please help me. 


Thank you 

redacted.png

 

Replies 4 (4)
james-langille
Shopify Staff
65 14 18

Hello, @1point619 , welcome to the community!

I think you are experiencing two different issues.

1) You'll need to create your subscriptions through your app since the api client id of the creator needs to match the provided api client id (in the position of 5******5 in your request).

2) In the picture below, it looks like its complaining about your ARN not matching what we expect a valid ARN to look like in our validation. I'm no expert on AWS, but from what I can tell there are 2 differences between what you're providing and what we expect:

  1. We expect 'event-source' instead of 'event-bus'
  2. We expect that you don't specify the account id at all '3********6' to leave it as a wildcard

So, together something like this would pass our validation (if you're creating from the app, which has api client id 5****5):

"arn:aws:events:us-east-1::event-source/aws.partner/shopify.com/5****5/us-east-1"

Let me know if these requirements are a blocker for you, and hopefully this helps!

james-langille | Developer @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

1point619
New Member
2 0 0

Thank you James for clarifying that the app instead of the graphiql app should be used. Also, I'm kept on using the wrong url, massive oversight.

I still get the error though I think it's probably how I've set it up. May be I missed another step in the EventBridge tutorial . Thank you so much for your timely response

 

redacted2.png

jfdha
New Member
1 0 0

I got to the same place as the previous message, seeing the message 'Address is invalid' when trying to register an EventBridge webhook. This is after a fresh install of the Shopify CLI, a fresh "shopify node create" and following the instructions on the Shopify EventBridge integration tutorial.

I noticed that the version of the node library "@shopify/shopify-api" in package-lock.json was 1.2.1, whereas the latest version as of today is 1.4.1 (20th October 2021). The library must be installed as a dependency of something else in package.json as it's not explicitly listed. But you can update it by installing it specifically:

npm i @shopify/shopify-api

which will install the latest one. From here things worked for me to register the webhooks. Would be great to bump the minimum version of the dependency in whatever requires the client library so it works out of the box!

Soufian
New Member
2 0 0

Hi,

I have the same problem. I could add the topic products_updates, but there is a problem with the topic products_create.

AWS returns an ARN containing 4932145 and I can't find a way to return one with 5006859 like for products_updates

aws.partner/shopify.com/5006859/products_updates

Screenshot 2021-11-15 at 15.32.41.png

The consequence is that when posting the new ARN Shopify specifically expectes an ARN containing 5006859

Screenshot 2021-11-15 at 15.34.30.png

Any help would be greatly appreciated.

Cheers