FROM CACHE - en_header

Can't get shopify on graphql - gatsby program is not working

11 0 4

I am using gatsby and I can't get shopify on the graphql so the program is not working.  I have tried everything. Below is my config. I have tried to put the shopify info in a .env file but that didn't work. Is there something that I should do in graphql to load shopify?

conf file below

module.exports = {
  siteMetadata: {
    title: `Gatsby Shopify Starter`,
    description: `Gatsby & Shopify Starter for the WebDevEducation course.`,
    title: `MadHatter Store`,
    description: `We're mad about hats`,
    author: `@tomphill`,
  plugins: [

      resolve: `gatsby-plugin-google-fonts`,
      options: {
        fonts: [
          `open sans\:400`,
          'open sans:400i',
          `open sans\:700`,
          'open sans:700i',
          `open sans\:800`,
          'open sans:800i',
      resolve: 'gatsby-source-shopify',
      options: {
        shopName: `Bumples`,
        apiVersion: '2020-10',

      resolve: `gatsby-source-filesystem`,
      options: {
        name: `images`,
        path: `${__dirname}/src/images`,


      resolve: `gatsby-plugin-manifest`,
      options: {
        name: `gatsby-starter-default`,
        short_name: `starter`,
        start_url: `/`,
        background_color: `#663399`,
        theme_color: `#663399`,
        display: `minimal-ui`,
        icon: `src/images/gatsby-icon.png`,
thanks, hope someone has the answer.


Replies 0 (0)