FROM CACHE - en_header

carrierService has stopped posting to callback_url

dedev
New Member
1 0 0

A custom carrier service that has worked on my store for years stopped working last night.

The callback_url endpoint for the service is on my server. Checking the access logs, I see no inbound requests from Shopify since midnight.

I've confirmed that the callback_url is generally accessible on the internet (i.e. from multiple browsers/machines)

I've tried removing the carrier service, renaming the endpoint, and re-adding. Even with service_discovery set to "true", I still don't see a single call on my end from Shopify.

Are there any tools I can use to further diagnose the issue? Is there any way to force a call from Shopify to the callback_url to at least verify connectivity?

Reply 1 (1)
_JCC_
Shopify Staff
Shopify Staff
180 25 36

Hey @dedev,

I apologize for the delay in getting a response to this. Is this something that's still a problem? When reading the question my immediate thought was that the app carrier service rate had been removed from the shipping profile. If this is still an issue, I'd be happy too look into this some more. If you could DM me the store, and the date and time in UTC when a cart or checkout action should have called your endpoint I can have a look at the logs.

Regards,

John

John C | Developer Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog