Checkout API - The field buyer_accepts_marketing is not taken in account

Bkwems
Shopify Partner
5 0 1

Hi there,

 

We have a technical question regarding the Checkout API. Our app is a sales channel that allows our users to purchase from different Shopify stores.

 

Part of this process is to create a new Checkout object for the user's basket and WITHOUT marketing - because we already have our own email marketing flows (abandoned cart, order confirmed, etc.). 

 

Nevertheless, it appears our users (and I tried it myself) still receive marketing emails such as the abandoned cart email or others even if I explicitly specified the field buyer_accepts_marketing to 'false' during the creation of the Checkout object.


In the official documentation, I can see the following:

 

buyer_accepts_marketing


Whether the customer has consented to receive marketing material via email.

(URL: https://shopify.dev/api/admin-rest/2022-01/resources/checkout#resource-object)

 

I would assume setting this field to false would prevent customers from receiving marketing emails, but it does not seem to be the case.

 

Please look into this as this is an issue for our customers as they currently receive duplicated emails?

 

Thanks,
Boris

Replies 2 (2)
Don
Shopify Staff
Shopify Staff
1947 136 259

Hi there @Bkwems!

 

I just wanted to let you know I have moved your query here to our dedicated API forums.

 

As we're unable to provide developer-level support ourselves, we have provided this area in the Shopify Community for sharing API-related queries.

 

These threads are monitored and responded to by our own developers and Partners, so it's the best place to share queries like this.

 

All the best!

Don | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Bkwems
Shopify Partner
5 0 1

Thanks for moving the subject.

 

Any help from any Shopify devs here? Just to add to my request. The field is NOT marked as read-only in the documentation.

 

How can I specify this field to false by default?

 

Thanks,

Boris