Deprecated Alerts - Help!

momoramadori
New Member
3 0 0

Schermata 2021-08-19 alle 08.53.46.png

 Hi everyone!

Checking on the status of my apps I've found that there are 2 UPDATE DEADLINES that I have to meet.

I've checked both of them but I'm not sure on how to solve the issues.

 

Topic 1: Accepted application charges will now be automatically transitioned into an active state.

Looking in the doc: The application charge has been accepted by the merchant and is ready to be activated by the app. At this point it will appear on the merchant's invoice. As of API version 2021-01, when a merchant accepts a charge, the charge immediately transitions from pending to active.

On my application I'm actually using the activate.json call. Is it sufficient to remove this call to remove this alert? 

 

Topic 2: Your app is subject to breaking changes. Check the release notes to keep your app up to date.

As you se from the screen the issue is related to Shop endpoint. Looking into release notes I can see that the only breaking change is related to uploadImages that I am actually not using. In this case I have only to ignore this alert?

 

Thanks in advance for your help!!

 

Replies 5 (5)
csam
Shopify Staff
Shopify Staff
267 40 43

Hi @momoramadori 

You can use the Deprecated API calls API in order to identify any calls your private app is making. Calling this endpoint will return a list of all the deprecated calls your private apps have made in the past 30 days, information on migration steps, and the deadline to update these calls in your apps. You can read more about it in our documentation here: https://shopify.dev/api/admin/rest/reference/deprecated_api_calls

Regarding the payments API, you're correct, the activate.json endpoint has been removed, it is no longer required to transition the charge from pending to active.

It looks like there have been a few fields deprecated from Shop - https://shopify.dev/api/admin/rest/reference/store-properties/shop - so I don't know for certain what may be causing the alert for your app. You should be able to find any deprecated calls that might affect your app by accessing the deprecated_api_calls endpoint I mentioned above.

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

momoramadori
New Member
3 0 0

Hi csam,

thanks a lot for your answer!

Just another question:

I'm experiencing issues in performing the deprecated_api_calls API call, I receive always an error 404 in response.

I read that the deprecated_api_calls API has to be performed for a specific version but I tried all the versions from 2020-01 to 2021-07 and I always receive a 404 error.

Example url: https://store-name.myshopify.com/admin/api/2021-07/deprecated_api_calls.json

Could you please give me more details on how to perform correctly the API call? 

N.B. actually we are not specifing the API version on calls, can this be the reason of the 404 response? 

Thanks in advance,

Momo

csam
Shopify Staff
Shopify Staff
267 40 43

Those versions are working for me when I test with my own app and store. Are you using private app credentials? If you're still seeing the 404, can you please send post the x-request-id header field here? I can try to take a look in the logs to see if there is an issue.

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

momoramadori
New Member
3 0 0

We are an API integrator,  I'm sending on of our customers' stores request!

x-request-id with no version 92801128-afd4-4d66-a42d-c6a9765199a2

x-request-id with version 2021-07 : 18111926-8394-437d-96f3-2c54a3433612


Thanks in advance,

Momo

csam
Shopify Staff
Shopify Staff
267 40 43

Hi Momo,

Thanks for the examples, I didn't realize you were referring to a public app. The deprecation endpoint only works for private apps, so you won't be able to find any information there.

Based on the alerts you're receiving, I would recommend removing the unnecessary activate.json calls, and adding current versioning to calls made to Shop.

 

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog