FROM CACHE - en_header

Localhost in oAuth doesn't redirect on the url I set in App Settings

Solved
AntonPluzhnikov
Shopify Partner
11 2 2

Hi,

my custom app has this redirect url: https://localhost:44345/...../Callback

But instead of shopify redirecting to the url I set in the options when I run a Merchant install link it gets redirected to https://localhost:44345/?hmac={hmac}&shop={MYSHOP}.myshopify.com&timestamp={timestamp}

What is going on? Why I'm redirected to a wrong page and why there is no code?

Shopify doc doesn't hold any information about how I can test app on a localhost

 

Best regards, Anton.

Accepted Solution (1)

Accepted Solutions
AntonPluzhnikov
Shopify Partner
11 2 2

This is an accepted solution.

Hi @najeeba ,

I found a mistake I make. The url I was passing had an invalid parameter. Once I removed it I successfully receive the callback

I tried couple of times and didn't experience any issue so far.

View solution in original post

Replies 5 (5)
najeeba
Shopify Partner
13 2 4

Hi Anton,

Did you find any solution to this issue? I'm having this issue on every alternate installations, ie, it happens in the 1st, 3rd, 5th, ... tries.

AntonPluzhnikov
Shopify Partner
11 2 2

hi @najeeba ,

nope, 2 month and still no reply from Shopify team
I sent them an email yesterday, hope they will reply soon 

Best regards, Anton

AntonPluzhnikov
Shopify Partner
11 2 2

This is an accepted solution.

Hi @najeeba ,

I found a mistake I make. The url I was passing had an invalid parameter. Once I removed it I successfully receive the callback

I tried couple of times and didn't experience any issue so far.

najeeba
Shopify Partner
13 2 4
Hi Anton_Pluzhniko,
Thanks for your update on the issue. In my case, it seems the issue is
there on my browser only. Checked with some of my colleagues and it is
working fine for them. So we have left it as it is for now. Hope it won't
cause any issues in future!

--

Alex312
Shopify Partner
11 0 8

This was my issue. Did not work in Chrome, opened Edge, worked immediately using http://localhost:4000/api/integration/shopify/auth/callback