MediaImage failed to process

timolins
New Member
10 0 0

One of my customers just messaged me that some of their images are missing inside my app. 

I did some investigations and it seems like the affected images have the following error, even though the status is set to READY.

 

 {
   "node": {
     "__typename": "MediaImage",
     "id": "gid://shopify/MediaImage/7412102594640",
     "mediaContentType": "IMAGE",
     "mediaErrors": [
       {
         "code": "IMAGE_PROCESSING_FAILURE",
         "message": "Media failed to process because the image could not be processed"
       }
     ],
     "status": "READY",
     "image": null
   }
 }

 

 

The image can be obtained by using `images` (instead of `media`), so it is definitely uploaded successfully.

 Is there any way to fix broken images like this?

Timo Lins ~ Founder @ PS Tunnel
Connect Photoshop to Shopify.
Edit and upload product images instantly. ✂️

Replies 19 (19)
_JB
Shopify Staff
Shopify Staff
836 99 211

Hey @timolins,

I checked our logs and I'm seeing this error message mentioned: "process_images failed because image transformation failed with: Could not determine dimensions". I agree this shouldn't be the case if the same image is working as a regular image (non-media) upload. 

I've downloaded the image which is giving an error, would you mind providing the URL for a different image that was uploaded successfully in the same job? I'll send these over to our developers and they should be able to figure out what's happening.

JB | Solutions Engineer @ Shopify 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

N_Art
New Member
2 0 0

I’m having this same issue. I haven’t looked at the coding, but my images were at 5.6 MB when I first uploaded and now that I’m trying to add another image that is just.3 MB larger, I’m getting a processing error on the app but being told that my image shouldn’t be larger than 20 MB?? I even flattened the image and made it 2.8 MB and am still getting the same issue....

thetiredealer
Tourist
4 0 2

Hello I am having the same issue, for some reason the image is not uploading. Was there any update on this issue? 

 

_JB
Shopify Staff
Shopify Staff
836 99 211

In order to further investigate issues with image uploads, please provide the MediaImageID or X-Request-ID value from the response headers of a call that experienced the issue. 

JB | Solutions Engineer @ Shopify 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

K_U_
New Member
1 0 0

Hello,

When I try to add image from this URL (anyone who has the link can open it), I receive the following message:

"Media upload failed

Some of your media failed to upload, please retry again.
  • Image: Media processing failed"

Why does it happen? How can I upload images from similar addresses?

Thank you!

msawyer9616
Tourist
6 0 1

I am experiencing this same issue, any resolution steps? Do I need to change code to get media uploaded to product photos via YouTube link?

_JB
Shopify Staff
Shopify Staff
836 99 211

@K_U_ 

I clicked the link you provided but it's asking me to sign in to a Microsoft account. Shopify won't be able to download an imaged gated by an authentication process, so you'll need to host that somewhere else.

@msawyer9616 

Please provide a URL to one of your images here and we can take a look. Note that the image has to be directly accessible from that URL.

JB | Solutions Engineer @ Shopify 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

canfernee
Shopify Expert
1 0 0

Hi, all~ 

I'm having the same issue with my shop. I used to be able to upload gifs but now, I can't. I keep getting the same error: 

  • Image: Media failed to process because the image could not be processed

Hoping for help on this. Thank you~ 

Joiakim
New Member
8 0 0

I'm having the same issue when processing images from a CSV file. All my jpg images succeeded to upload but the png images didn't. Which format are your images? I assume this is due to whether the format or the file weight. 

Big4rest
Tourist
3 0 1

Hi everyone, I am also facing the same problem, for some reason the image is not uploading. Has anyone been able to solve this problem?

xplication
New Member
1 0 0

We are facing the same problem with one of our client's websites. Can you please provide some information on how to fix this problem.

 

The thread was opened for almost a year.

 

Thank you!

snh1029
New Member
1 0 0

I don't know if this will work for you, but I had the same problem but when I uploaded the media by URL it worked for me

ccanete
New Member
1 0 0

I have the same issue on my hand. Anyone who've found a workaround ?

Joiakim
New Member
8 0 0

On my side, I was able to fix the problem by removing the transparency of my PNG file or simply using 8-bit format instead of 24-bit format . Alternatively, it will considerably reduce the file weight of your image. 

anapao
Tourist
5 0 4

same issue here with gifs for mail marketing campaigns, its really amazing how Shopify is ignoring this issue.

LFR
New Member
1 0 0

How do you upload with the URL?

Bluebelt
New Member
3 0 0

Hi , I'm using create product admin api with image is ipfs link ( example : https://ipfs.infura.io/ipfs/QmNN2K2fic6tBwNJZZLfakEzQVxrv7Bj5SKfx7v9DpNU26 ) but shopify return product without any image in it.

I also tried to use shopify admin to edit/create product directly and use link to file in media section , but still show 

Some of your media failed to upload, please retry again.
  • Image: Media processing failed

I tried to use another link (example : https://cdn2.thecatapi.com/images/MjAzMDEwNw.jpg) , it still works. So I wonder if shopify have any problem with ipfs host link.

Does anyone help ?

Upheavalart
New Member
1 0 0

Hey,

 

I was having the same issue when I was trying to upload 3 pictures.

2 of them failed to process. I realized that the only diference betwin the 3 pictures, was the name.

Both of the pictures that failed to process started with a ''.'' ( ex: .painting1 ; .painting2 ),  while the picture that succeeded to process, didn't have the '' . '' in the name (ex: painting3).

I deleted the "." from the name, tried again and it worked. I was able to upload the 3 pictures.

 

Hope this helps some of you!

 

 

baumant
New Member
1 0 0

Happening to me when trying to upload a .gif file to product photos, only 5MB