Not getting the "Install Unlisted App" popup for some reason.

New Member
2 0 2


I was following tutorial Build a Shopify App with Node and React , and in the "Embed your app in Shopify" section there's a step where I install the app in my development store. But there's something weird that's happening and I'm not able to figure out the reason,


When I click on install app, I don't get the "Install Unlisted App" popoup for some reason. Rather, I get the following screen directly


So now when I check my dev store, there are no apps installed,


I'm not sure how to get this working.

Replies 2 (2)
174 13 38

I haven't gone through this tutorial, but my hunch is either the code in your app isn't routing you to the permissionUrl: in the 'Authenticate with OAuth' section or perhaps something is up with that install link. I don't know what that install link does, I was never able to get it to work. Instead what worked for me was manually generating a permissionUrl like this:




Try that for your development store, you should see the OAuth prompt and you can proceed. 

Shopify Staff
Shopify Staff
318 42 61

Hey @satwik97 

I ran through the tutorial you are referring to and was able to get it to install into my dev shop without issue. I would suggest you try cloning the completed code from to see if that works for you. 

Kevin_A | Solutions Engineer @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit or the Shopify Web Design and Development Blog