Order in shopify admin opens normally, but api always returns not found.

Solved
marcoaurelio
Tourist
3 0 1

shopify2.png

Does anyone know what can it be?

0 Likes
csam
Shopify Staff
Shopify Staff
131 19 21

This is an accepted solution.

Hi @marcoaurelio 

Does the app you're using to make the API request have the read_orders scope enabled? You can check this using the API access scopes endpoint, or by looking in the Shopify admin under Apps > Manage private apps at the bottom of the page. 

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

0 Likes
marcoaurelio
Tourist
3 0 1

Hi @csam 

My app has read_order scope enabled.

This problem happens only with some order.

0 Likes
csam
Shopify Staff
Shopify Staff
131 19 21

Hi @marcoaurelio 

If this is still occurring for you, could you please fill out the API support form found under partner support in the "[Beta] Report an issue" section? We will need some additional information to investigate this, including an x-request-id from one of the empty responses as well as your application ID, and any other contextual information you can provide about the issue. Thanks!

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

0 Likes
marcoaurelio
Tourist
3 0 1

Hi @csam 

With a new key the problem has resolved.