Order send_receipt=false is ignored, even though Storefront API is disabled

AlexB3
New Member
1 0 1

Hi, I am creating orders via the REST API and am explicitly setting "send_receipt" to false. However, order confirmation emails are still being sent (I dont want them to be).

This page https://shopify.dev/api/admin/rest/reference/orders/order indicates that "If you're working on a private app and order confirmations are still being sent to the customer when send_receipt is set to false, then you need to disable the Storefront API from the private app's page in the Shopify admin."

I am using a private app. The Storefront API is disabled.

Can someone point out what I am doing wrong? (Thanks in advance!)

Replies 2 (2)
velipekkar
New Member
2 0 0

Hi, I'm having this same problem. Does anyone have any info on why this is happening?

velipekkar
New Member
2 0 0

I was able to solve this. We were using custom app and access token instead of private app credentials. Storefront API permission affects custom apps also but the permission has to be disabled from another page. I went to partners.shopify.com and from apps menu opened our application. On the top there is App Setup and from there I disabled Storefront API. Send_receipt now works like it should.

 

Hope this helps anyone with the same problem.