shopify_app gem upgrade: access_scopes= must be defined to hook into stored access scopes

TeejO
Tourist
5 0 0

I am currently upgrading an existing rails app from using the gem, shopify_app 17.1.0 to shopify_app 18.0.2. But when I deploy it, on shops that already have the app installed, there one issue I seem to be having.

 

access_scopes= must be defined to hook into stored access scopes

 

 

The error can be traced here: https://github.com/Shopify/shopify_app/blob/master/lib/shopify_app/session/shop_session_storage_with...

The 17.1.0 version seems to have the same line: https://github.com/Shopify/shopify_app/blob/v17.1.0/lib/shopify_app/session/shop_session_storage_wit...

Is that a requirement in version 18.0.2 now?

 

Edit: I have added access_scopes column already in the Shop model but that doesn't make the problem go away.

Replies 0 (0)