[SHOPIFY CLI BUGGED] I can't pull/push clients theme using Shopify 2.0 CLI.

relativelynew
Tourist
12 0 2

Hi everyone,

Recently one of my clients moved to a 2.0 theme. Now they are asking me to make small changes on their store. I need to edit code on their store.

 

Here is what is happening.

1- I can go to their_domain.myshopify.com/admin and login to their store.

2- In their admin panel, I can change/edit their theme code, as well as upload a new theme from zip file.

 

On the other hand, I get an error when I try to do the following:

1- I type : shopify login --store=store-domain-here

2- This takes me to https://accounts.shopify.com/......

3- I click my account and I login to my developer account.

4- I see "Authenticated successfully. You may now close this page." message and the shopify cli asks me to pick an organization.

5- I pick the right organization, (I tried both org and none works)

6- I type : shopify theme pull

7- I get following error:

This command ran with ID: XXXXX
Please include this information in any issues/report along with relevant logs
Traceback (most recent call last):
36: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/bin/shopify:32:in `<main>'
35: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/error_handler.rb:21:in `call'
34: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/error_handler.rb:75:in `handle_abort'
33: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/bin/shopify:33:in `block in <main>'
32: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/core/entry_point.rb:23:in `call'
31: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/core/monorail.rb:20:in `log'
30: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/core/entry_point.rb:24:in `block in call'
29: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/core/executor.rb:15:in `call'
28: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:14:in `call'
27: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:43:in `with_traps'
26: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:55:in `twrap'
25: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:44:in `block in with_traps'
24: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:51:in `twrap'
23: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:45:in `block (2 levels) in with_traps'
22: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:15:in `block in call'
21: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:35:in `with_logging'
20: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-ui/lib/cli/ui.rb:176:in `log_output_to'
19: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:36:in `block in with_logging'
18: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-ui/lib/cli/ui/stdout_router.rb:169:in `with_id'
17: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:37:in `block (2 levels) in with_logging'
16: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:16:in `block (2 levels) in call'
15: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/command.rb:19:in `call'
14: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/sub_command.rb:13:in `call'
13: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/project_types/theme/commands/pull.rb:25:in `call'
12: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/form.rb:13:in `ask'
11: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/project_types/theme/forms/select.rb:8:in `ask'
10: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-ui/lib/cli/ui/prompt.rb:100:in `ask'
9: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-ui/lib/cli/ui/prompt.rb:188:in `ask_interactive'
8: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/project_types/theme/forms/select.rb:9:in `block in ask'
7: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/project_types/theme/forms/select.rb:20:in `themes'
6: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/theme/theme.rb:166:in `all'
5: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/admin_api.rb:95:in `rest_request'
4: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/util.rb:172:in `retry_after'
3: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/admin_api.rb:92:in `block in rest_request'
2: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/api.rb:86:in `request'
1: from /var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/vendor/deps/cli-kit/lib/cli/kit/util.rb:172:in `retry_after'
/var/lib/gems/2.7.0/gems/shopify-cli-2.3.0/lib/shopify-cli/api.rb:72:in `block in request': 403 (ShopifyCli::API::APIRequestForbiddenError)
{"errors":"Unauthorized Access"}

 

I tried all of the possible solutions at the https://github.com/Shopify/shopify-cli/issues/1361#issuecomment-879426041 link. Nothing worked.

 

How can I pull/edit/change/push the files on client store using the new shopify CLI? From the comments on the GitHub, it seems like this tool is severely bugged but there has not been any solutions?

 

Thanks.

 

 

 

Replies 3 (3)
Elena_M
New Member
2 0 1

Hey there, had the same issue. Check the comment from tommypepsi, it solved the issue for me: https://githubmemory.com/repo/Shopify/shopify-app-cli/issues/1421

Dmytro733
New Member
1 0 0
SheDevs
New Member
2 0 0

This is happening to me too. The solution from tommypepsi did not help my situation. I am trying it with a clean new user and partner account