Shopify CLI log in issue

Solved
shaggydimas
New Member
2 1 3

After running shopify theme serve command in the terminal and opening http://127.0.0.1:9292 link in the browser, I'm asked to enter the store password, after entering it tells me that the password is incorrect, and I'm sure it is correct. After couple of tries, I clicked on the – "Are you the store owner? Log in here" link below the password field, which takes me to shopify choose account page, and after logging in there it gives me the following error page: 

Screenshot 2021-09-13 at 1.46.15 AM.png

 

The first time I tried to run the store on localhost was 4 days ago and had this error and thought there's a problem on shopify end. Now I tried this today and the problem is still there. 

What can I do to fix this?

Accepted Solution (1)

Accepted Solutions
shaggydimas
New Member
2 1 3

This is an accepted solution.

Coming back months later to this problem I finally fixed it. You should enter not your store password itself, but Password protection, which you can find in Online store -> preferences -> Password protection.

Cheers

View solution in original post

Replies 4 (4)
csam
Shopify Staff
Shopify Staff
267 40 43

Hi @shaggydimas 

Are you following the tutorial here? https://shopify.dev/themes/getting-started/create Can you confirm you have either an owner or full staff account on the store?

I would recommend clearing your cookies and cache and confirming that you do have access to the store. In the command line, you can run 

shopify whoami 

to make sure that you are authenticated with the correct account and permissions.

You can also try posting on the Shopify CLI Github repo if you're still having difficulties authenticating. 

CS | API Support @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

Juu
New Member
1 0 0

I'm getting the same issue. Please help

shaggydimas
New Member
2 1 3

This is an accepted solution.

Coming back months later to this problem I finally fixed it. You should enter not your store password itself, but Password protection, which you can find in Online store -> preferences -> Password protection.

Cheers

travisrogers
New Member
1 0 1

I have the same issue with the password page displaying when I try to view my local build, but I the password modal doesn't show when I click on the customer 'Enter Password'. If I click on the 'Are you the store owner? Login Here' link it takes me to a Shopify login page, but then after logging in it takes me to the We'll be back soon page. If I try to use the password I've set up in my store preferences on the Shopify login it doesn't work. Only my Shopify Partners psw works and takes me to the We'll be back soon page.

 

I'm wondering if this is theme specific, but has anyone else had trouble accessing the password field to access their store when they're running it locally?

 

When I disable the password on my store and pull the theme again, the password page does not show when I open it locally on my machine, but then the load time is incredibly slow and some images don't come in at all (I'm on a 200 mb/s connection).

 

Any help would be super appreciated!