FROM CACHE - en_header

shopify-cli : "shopify node create" results in error

optimus1682000
New Member
1 0 0

I'm a newbie at using shopify-cli .

I am following the tutorial "How to Build a Shopify App".

Whenever I run the command "shopify node create" , and fill in my app name and submit .

I get the same error :  "/home/alfred/.rvm/rubies/ruby-2.6.8/lib/ruby/2.6.0/open3.rb:213:in `spawn': No such file or directory - git (Errno::ENOENT)"

The full stack trace is:

alfred@XXXX-ALF-LT-VB1:~/proj$ shopify node create
? App name
> test_ext_xxxx
? What type of app are you building? (You chose: Custom: An app custom built for a single client.)
This command ran with ID: 14454
Please include this information in any issues/report along with relevant logs
/home/alfred/.rvm/rubies/ruby-2.6.8/lib/ruby/2.6.0/open3.rb:213:in `spawn': No such file or directory - git (Errno::ENOENT)
from /home/alfred/.rvm/rubies/ruby-2.6.8/lib/ruby/2.6.0/open3.rb:213:in `popen_run'
from /home/alfred/.rvm/rubies/ruby-2.6.8/lib/ruby/2.6.0/open3.rb:101:in `popen3'
from /home/alfred/.rvm/rubies/ruby-2.6.8/lib/ruby/2.6.0/open3.rb:281:in `capture3'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/system.rb:194:in `delegate_open3'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/system.rb:90:in `capture3'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/context.rb:493:in `capture3'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/git.rb:112:in `exec'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/git.rb:118:in `rev_parse'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/git.rb:24:in `sha'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify_cli.rb:169:in `sha'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/api.rb:110:in `default_headers'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/api.rb:56:in `block in request'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/util.rb:172:in `retry_after'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/api.rb:86:in `request'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/api.rb:36:in `query'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/partners_api.rb:49:in `block in query'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/util.rb:172:in `retry_after'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/partners_api.rb:50:in `query'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/partners_api/organizations.rb:6:in `fetch_all'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/tasks/select_org_and_shop.rb:28:in `organizations'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/tasks/select_org_and_shop.rb:39:in `get_organization'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/tasks/select_org_and_shop.rb:11:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/task.rb:7:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/project_types/node/forms/create.rb:13:in `ask'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/form.rb:13:in `ask'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/project_types/node/commands/create.rb:22:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/sub_command.rb:13:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/command.rb:19:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:16:in `block (2 levels) in call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:37:in `block (2 levels) in with_logging'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-ui/lib/cli/ui/stdout_router.rb:169:in `with_id'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:36:in `block in with_logging'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-ui/lib/cli/ui.rb:176:in `log_output_to'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:35:in `with_logging'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:15:in `block in call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:45:in `block (2 levels) in with_traps'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:51:in `twrap'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:44:in `block in with_traps'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:55:in `twrap'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:43:in `with_traps'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/executor.rb:14:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/core/executor.rb:15:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/core/entry_point.rb:24:in `block in call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/core/monorail.rb:20:in `log'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/lib/shopify-cli/core/entry_point.rb:23:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/bin/shopify:33:in `block in <main>'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/error_handler.rb:75:in `handle_abort'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/vendor/deps/cli-kit/lib/cli/kit/error_handler.rb:21:in `call'
from /home/alfred/.rvm/gems/ruby-2.6.8/gems/shopify-cli-2.1.0/bin/shopify:32:in `<main>'

 

my node version is :

alfred@XXXXX-ALF-LT-VB1:~/proj$ nvm current
v14.18.0
alfred@XXXXX-ALF-LT-VB1:~/proj$

 

I am getting exactly the same error when I installed Ruby version 3.0.0. and Shopify-Cli version 2.6.3

Have I missed out something else which I need to install in my local development environment?

Thanks in advance for your help!

 

 

Replies 0 (0)