Adding theme 2.0 app requirements (alongside geography and sales requirements)

Adding theme 2.0 app requirements (alongside geography and sales requirements)

Josh_at_Flare
Shopify Partner
3 0 7

Hi everyone! 🌟

We've been exploring how to set install requirements for our apps based on sales channels and geography, which got us thinking about another important field – Shopify themes.

Specifically, is there a way to set install requirements based on the Shopify theme version, like for 2.0 themes exclusively, as opposed to 1.0 themes? We're aware of the JavaScript snippet in the documentation that detects Shopify 2.0 themes, but this comes into play post-installation.

If there was a field for theme requirements, it seems like it could be a win-win – more apps get installed by compatible merchants, and more merchants see the value from using 2.0 themes.

Looking forward to hearing thoughts!

Reply 1 (1)

AlexHooper
Shopify Partner
22 0 15

This would be so useful!

AH