App Is Outdated

RtDev
Shopify Partner
5 0 0

Hi @olavoasantos  , 
So i am having these errors from the Shopify team/email side regarding the app.
Error message : https://prnt.sc/2S7_OA_F5E12


Requirement : https://prnt.sc/hToUBj4XMUw-
(1) App Bridge 3.0 : https://prnt.sc/ebYgBSrLdQLt
(2) Content Security Policy : https://prnt.sc/lY-W8poITo2u
(3) Host Parameter Included : https://prnt.sc/qWDGdFBp6Z7F


So we have done everything, However that error is not solving on that domain and the app remains delisted.
Please suggest something. 

banned
Replies 6 (6)
RtDev
Shopify Partner
5 0 0

Thank @mingw , I can see that in the github this issue is not solved and people does not have much idea on this.

However @olavoasantos Merchants should not see this error or this will break the business.
Also we partners have no idea why this is happening.

Please help on urgent basis as our app is delisted and business is getting affected.

banned

bratsos
Shopify Staff
1 0 1
Hi @RtDev, thanks for providing all the info.
Have you been provided with a reason why your app was delisted?

I am asking because I think it’s a separate issue from the outdated banner.

As for the outdated banner, I would like to verify that you’re in fact initializing App Bridge correctly:
  • In the screenshot you included, I noticed that the value of the host is hard-coded.
  • I also noticed that the app is loaded successfully inside stokesapp-testing.myshopify.com.
When you test your app in admin.shopify.com/store/stokesapp-testing, are you using the same hard-coded host value?
If so, can you please change the hard-coded value to be new URLSearchParams(location.search).get("host") , as shown in this section of the docs.
 
Let me know if this resolves your issue.
 
Thanks!

To learn more visit the Shopify Help Center or the Community Blog.

RtDev
Shopify Partner
5 0 0

Thanks @bratsos For your response.

 

I have hard coded it as my application is in staging environment. Also i have seen that Shopify only provide the host in the first initial load only and later we have to save it in the database and retreivef from there right ?

Because currently i have the host paramter in my iframe url but when i debug it with console.log i get null values.

 

 

However one thing is clear that even if i hard code it, it is the same i get for my this store.
So the app should not get broken here.

My Dynamic Code : https://prnt.sc/SXQt8QGmUH2i
Null Output : https://prnt.sc/Jhb8M0kT1B16

However my hard-coded host is right for this store : https://prnt.sc/fFb3u3KDNbce


Please check on this and let me know, I am in talk with various other develoeprs and we are all stuck. If you check this github post, various Shopify partners are facing this issue.

https://github.com/Shopify/shopify-app-bridge/issues/160
Please check & guide me on this. I know the right practices & hard-coded ways, I have tried them all.



banned
RtDev
Shopify Partner
5 0 0

 @olavoasantos  Could you please check & provide your thoughts ?

banned
RtDev
Shopify Partner
5 0 0

 @olavoasantos  Could you please check & provide your thoughts ?

banned