Are theme app extensions compatible with online stores before 2.0

shubh_tibra_kom
New Member
1 0 0

I am developing an app with theme app extension.

I used this command: "shopify extension create --getting-started" which creates a sample theme app extension (https://github.com/Shopify/theme-extension-getting-started). Now I am developing my app by editing this code.

The documentation says theme app extension only available in development store but it's not clear if this will work for existing Shopify stores.

What exactly is online store 2.0? Do I need to develop two apps for both versions (1.0 and 2.0)? Will my current app work in all shopify stores?

 

0 Likes
chenster
Pathfinder
107 4 13

It would require the store to use newer themes compatible with new online store 2.0 that support JSON template. The older theme would need to be updated by its developers first. 

Cartoo
0 Likes