GraphQL Calls failing in 3.49.5 cli without use_legacy_install_flow flag

ndt_ts
Shopify Partner
24 2 6

Hi,

I have been previously using 3.48.1 cli version and i was able to perform graphql calls for

1. Payment Customization
2. Theme Extensions
3. App Level Metafields

Everything was working fine and suddenly today when i tried to create a new app with extensions,
i came across the documentation for payment customization that cli: 3.49.5 is needed. So i used the latest remix template and created all my extensions.

When i tried to perform my graphql calls from the remix shopify app, it fails and gives me the below error:

{
 size: 0,
 [Symbol(Body internals)]: {
  body: null,
  type: null,
  size: 0,
  boundary: null,
  disturbed: false,
  error: null
 },
 [Symbol(Response internals)]: {
  url: undefined,
  status: 401,
  statusText: 'Unauthorized',
  headers: {
   'x-shopify-api-request-failure-reauthorize-url': 'https://my-shopify-app.com/auth?shop=mystore.myshopify.com'
  },
 counter: 0,
 highWaterMark: undefined
}
 }


And my app crashed owing to the failed graphql calls.

When i tried going to the url within x-shopify-api-request-failure-reauthorize-url , it again opened my app and this time, the graphql calls got executed.

I didn't experience this strange behaviour before.

I added use_legacy_install_flow = true in shopify.app.toml and i reinstalled my app and my graphql calls are working like before without giving the above error message.

use_legacy_install_flow was part of my 3.48.1 template and i removed it in 3.49.5 as the default template for 3.49.5 was not having it.But since i was getting the above error, i tried adding this flag again in my 3.49.5 template and it works!

am i right in adding use_legacy_install_flow = true ?
what is use_legacy_install_flow and will it cause any issues in using it with 3.49.5 or above cli version?

kindly someone give some insights on it please!

Replies 0 (0)