Ngrok tunnel has timed out

1 0 0



I'm currently trying to do the following tutorial:

Env: Shopify CLI version 2.7.0, macOS, Iterm using zsh


This uses new commands as shown in the tutorial above. I am using `shopify app create node` to create my new embedded app.


The initial setup of the app is fine, but when trying to serve the app locally using `shopify app serve`, i run into ngrok problems, telling me that the tunnel has timed out.


I shouldn't have any tunnels running before i start the app, and i can confirm that by running `shopify app tunnel stop`, to which it says `ngrok tunnel not running`


I've tried things like deleting the cache from `./.cache/shopify`, restarting my computer, restarting VSCode and making sure no other processes are running.


Below is a screenshot of my steps

Screen Shot 2021-11-16 at 1.48.07 PM.png

stopping any existing ngrok tunnels:

Screen Shot 2021-11-16 at 2.22.13 PM.png

Any help is greatly appreciated! 

Reply 1 (1)
Shopify Partner
15 1 2

I ran into a similar problem and found this post. The command "shopify app tunnel stop" did terminate the ngrok tunnel for me, but I had to take is one step further before serving to another tunnel.


I had to "killall -9 ngrok" in order to successfully reopening a tunnel.