Open app button redirect to force_legacy_domain=1

Open app button redirect to force_legacy_domain=1

sonali-wm
Shopify Partner
2 0 2

I am passing content-security-policy. Still, it redirects to force_legacy_domain=1. 

 

Screenshot 2023-08-30 at 11.39.34 AM.png

 

Does anybody have the same problem?

Replies 8 (8)

remy727
Shopify Partner
41 2 22

I had the same issue with the outdated app.
Which version of @Shopify/app-bridge are you using?

Looking for a Shopify App developer? Please visit: https://github.com/remy727
sonali-wm
Shopify Partner
2 0 2

i am using app bridge version 3

Vanfigs
Shopify Partner
11 0 6

We're encountering the same issue. AppBridge 3.1, passing the security content, using the host parameter. The app was originally templated from shopify-app-template-node Version 1

magnalister
Shopify Partner
10 0 10

We have the same problem.

But I think it is not caused by AppBridge.
Because it appears in applications that don't use AppBridge.

Vanfigs
Shopify Partner
11 0 6
Thanks for the suggestion. It didn't work for us though. Shopify says there
are some issues on their side as well
jverbys
Shopify Partner
1 0 2

The same thing is happening for me at the moment.

 

I built an app with AppBridge 3.7.9.

 

Upon loading the app, shopify opens a new tab with force_legacy_domain=1

movsumov
Shopify Partner
76 5 25

Is this problem fixed now? I guess it is some kind of cache on Shopify side as we enabled embedded app recently.

Vanfigs
Shopify Partner
11 0 6
Hi! The problem is fixed now. It was fixed from Shopify's side. Something
to do with our legacy Listing.