product doesn't show on website

Mosto
Visitor
1 0 0

I used DSers to import products from aliexpress to my shopify sites and after pushing the product to the site the product was shown on the products section but wasn't shown when entering the website.

can someone help me fix it?

thank you!!!

 

Mosto_0-1665497608054.png

Mosto_1-1665497637316.png

 

 

Replies 4 (4)

Mac
Shopify Staff
1601 167 236

Hi, @Mosto!

Thanks for reaching out in our Community forums and for sharing your concern, I’d be happy to help.

 

Great job on setting up your DSers account to import products. While there can be a few reasons as to why this is happening, let's go through a few common troubleshooting steps. Firstly, you will want to make sure that your product is available to your active sales channel, which in this case is the Online Store. If the product is not available, then it will be hidden from that channel. To do this, you will want to click on the product to open its details, and under the product status section, click on active. Then, ensure that the Online Sales channel is selected. More instructions on this can be found via our help document

 

Since you're already able to view the product in the Products section, you will want to ensure that they are correctly linked to your store and menu. To do this, I'd suggest adding them to a specific collection and linking it directly to your shop

 

If you have any other questions, feel free to follow up and let me know! Additionally, I'm always looking to help out merchants with ideas or feedback related to their stores! 

Mac | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Kyle123456
Visitor
2 0 1

Hello,

 

Its sounds like I'm having the same issue. the product has loaded onto my product page as active. I added it to a collection which is connected through my navigation.  Ive added many products understanding these requirements but for some reason when I go to my live website, it doesnt appear there.  The collection is tagged in my navigation. This makes no sense to me.  Please advise. Thank you

Mac
Shopify Staff
1601 167 236

Hi there, @Kyle123456!

Thank you for joining this thread.

 

I understand that you are currently in the process of importing your products to your storefront but are encountering some issues. There could be a few possible causes for this, with the most common being an incorrect collection linked in your navigation or a display issue in your theme.

Since you have already completed the troubleshooting steps, it may be necessary for us to access your account to gather more information. While we are unable to provide account-specific support through the Community Forums, we would be happy to continue assisting you through our Help Center. To access our live support, you can ask the Virtual Shopify Assistant to "contact support." It will then guide you on the next steps to connect with a team member who can provide further assistance when viewing your account.

 

Let me know how that goes!

 

Mac | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

TheShopGuy
Visitor
1 0 0

Here's what you do to solve your problem. Go to Dashboard > Products > click on the product you want active... Then under the status modal on the top right look for the "publishing" modal. Hit the 3 dots > manage sales channels > check "online store" click done and save it. Should show up now.