FROM CACHE - en_header

"shopify login" Not working on Linux Manjaro ( using shopify cli in Terminal )

New Member
1 0 0

Hey !
I'm trying to login To my shopify store using shopify cli on Linux Manjaro but I still have errors !

first launch of the "shopify login" command i get this error :

Before Editing the file xdg-open.png


so i tried to edit xdg-open file :

Before Editing the file:

 if [ x"$BROWSER" = x"" ]; then
        if has_display; then

After Editing the file ( i added chromium in the first line and before :mozilla)

   if [ x"$BROWSER" = x"chromium" ]; then
        if has_display; then

And i Got this :

After Editing the file_ xdg-open.png

I tried to open the url using "xdg-open my-url" command (without using sudo)  but I got that :

after opning the url manually.png

my personal opinion on this error : 

I think the "shopify login" command is trying to open the url as root because when i run "sudo xdg-open my-url" i got the same error so I had to use the command without sudo , in any case I can manually open the url but I can't login !!!

if "the root access" is the cause, I don't know how to force "shopify login" to launch the url without root access .. , otherwise I don't know what to do is there a solution please ??

Replies 0 (0)