Shopify app unresponsive after heroku deployment

New Member
5 0 0


My app works fine when I run it locally from my code editor (shopify.bat serve) but when I deploy to heroku, and I click the link, I get this 


Also, when I open the app from any store, the page becomes unresponsive 


I saw a similar post and it was solved by committing the code and then "git push heroku master". 

I have done that as well but it doesn't help

I have also put in all env variables in heroku. I am a bit sceptical if I put the right host ( I put the heroku url

I don't know what I am doing wrong. Please I will appreciate any help, thanks

Replies 2 (2)
Shopify Partner
284 42 85


In your first screenshot, in the url address, you have an undefined variable. https://undefined

So it must be that you have an undefined variable in your heroku. Looks like the app url is not properly set up in heroku configs.

New Member
5 0 0

Hi Jayvin, 

Thank you for taking your time to check and reply to my issue. 

All my variables in heroku is defined. I can show you my variables in heroku so you can see if I'm doing something wrong.


Do I need extra variable? This much works in local editor with ngrok url as host. You mentioned app url not being properly setup but I have my host as according to the image above. Is that wrong?