Translation Lab not working in checkout

Solved
PureTime
Explorer
53 2 13

I am using the Translation Lab app for multi-language, and it's really a fantastic, free app.

However, for some reason it does not work in checkout. Checkout always shows my native language although it's translated in the Translation Lab app.

I've contacted the app developer, but they can't see anything wrong as they just provides the translation.

I've contacted Shopify support. They DO see the checkout translated (from native Danish to English), so they say there is no issues.

However - all my foreign (non-Danish) customers I've talked to tell me they got the checkout in Danish - and all tests run by both the Translation App developer and several of my friends all around the world show the checkout in Danish all the time.

I have no clue as to why Shopify themselves as the only ones in the world see it in English, but I can't get anymore support.

Does any of you wise guys have an idea to solve this? I would hate to have to export and set everything up in Langify (which would be my next step as I know from previous shops that they can handle the checkout).

You can test for yourself here - but I'm pretty sure you will see checkout in Danish as well if you put any item to the cart and go to checkout:

https://puretime.dk/en

Accepted Solution (1)

Accepted Solutions
Taras1
Shopify Partner
25 2 16

This is an accepted solution.

When I go to your checkout and add ?locale=en parameter, the page is really shown with the translation. This means that the content is actually translated

The problem might be that your checkout button is not retaining the language. This could happen in several cases:

your form action takes to ="/cart" instead of ="/en/cart".

I suggest checking your theme and if you have "/cart" anywhere in the .liquid templates, change it to corresponding routes object: "{{ routes.cart_url }}"

 

If this is not the case, the 2nd step would be to check if there are any js scripts or 3rd party apps that are affecting your checkout button. They could be not compatible with multilanguage and thus take you to Danish checkout instead of English one.

View solution in original post

Replies 13 (13)
Taras1
Shopify Partner
25 2 16

This is an accepted solution.

When I go to your checkout and add ?locale=en parameter, the page is really shown with the translation. This means that the content is actually translated

The problem might be that your checkout button is not retaining the language. This could happen in several cases:

your form action takes to ="/cart" instead of ="/en/cart".

I suggest checking your theme and if you have "/cart" anywhere in the .liquid templates, change it to corresponding routes object: "{{ routes.cart_url }}"

 

If this is not the case, the 2nd step would be to check if there are any js scripts or 3rd party apps that are affecting your checkout button. They could be not compatible with multilanguage and thus take you to Danish checkout instead of English one.

View solution in original post

PureTime
Explorer
53 2 13

Thanks for the input.

However, do you think it is the cart link that's wrong?

The cart shows fine in English - it is the checkout part that does not work in English?

 

This is how it currently links to checkout - Im not sure where to change that?

 

<button type="submit" name="checkout" class="btn">{{ 'cart.general.checkout' | t }}</button>

PureTime
Explorer
53 2 13

I found the problem.

The app Bundles Bear was causing the issue 

Taras1
Shopify Partner
25 2 16

To check the cart link you need to look not at the <button>, but at the <form action=...> part. When I checked your store from outside the link was ok. I also didn't see any scripts that caused the problem. But I'm glad that you managed to sort this out

PureTime
Explorer
53 2 13

Bundles Bear already released a new app version that does take into account the locale - nice!

Kevin99999
Tourist
7 0 4

Hi,

 

I have the same issue, translation lab doesn't translation my checkout page from French to English...

My website: www.medicosante.ca

I don't know how to fix it...

Please help!

thanks

Taras1
Shopify Partner
25 2 16

Kevin,

In your cart template .liquid search for

<form action="/cart"

and change it to

<form action="{{ routes.cart_url }}"

 

 

 

Kevin99999
Tourist
7 0 4

Hi!

It worked like!!!

THANK YOU SO MUCH FOR YOUR HELP!!

HAVE A GREAT DAY!!

Kevin

Hadi9
New Member
2 0 0

so helpful, thanks a lot!
Got fixed with this small change directly.