Solved

AppBridgeError: APP::ERROR::INVALID_CONFIG: ApiKey Must Be Provided

assafl
Shopify Partner
14 0 4

After upgrading shopify/koa-shopify-auth library to v5.0.3 I get this error message as part of the /auth route during application load.

 

I managed to track the root cause in the code to this new change:

https://github.com/Shopify/koa-shopify-auth/blob/15379030fd1677f4a37a215d080c19f3244047cd/src/auth/c...

 

It seems that although I initialize the context during app start, when the koa-shopify-auth package use it, its empty and not initialized

 

These version are being used:

shopify/koa-shopify-auth 5.0.3
shopify/app-bridge-utils 2.0.13
shopify/app-bridge-react 2.0.13
shopify/shopify-api 2.0.1

 

Any assistance will be appreciated

Accepted Solution (1)

SeanWilson
Shopify Staff (Retired)
3 2 2

This is an accepted solution.

Hi @assafl. Are you explicitly adding `@shopify/shopify-api@2.0.1` as a dependency to your project? If so, I'd recommend removing it from the package.json file, and implicitly use the version of the library included by the `@shopify/koa-shopify-auth` package because it uses v2.1.0.

To learn more visit the Shopify Help Center or the Community Blog.

View solution in original post

Replies 2 (2)

SeanWilson
Shopify Staff (Retired)
3 2 2

This is an accepted solution.

Hi @assafl. Are you explicitly adding `@shopify/shopify-api@2.0.1` as a dependency to your project? If so, I'd recommend removing it from the package.json file, and implicitly use the version of the library included by the `@shopify/koa-shopify-auth` package because it uses v2.1.0.

To learn more visit the Shopify Help Center or the Community Blog.

assafl
Shopify Partner
14 0 4

Eventually it was indeed a matter of using the correct versions for me

I must say that there was no place mentioning this relationship between the libraries and its importance for upgrading koa-shopify-auth package

 

Maybe you should consider specifying this as a prerequisite for the upgrading process