Cart App extension is not sending a POST request any more

Cart App extension is not sending a POST request any more

JasonWeber0
Shopify Partner
9 0 0

I've created a custom app using Shopify CLI and have my app embedded in Shopify POS.

When I try to add or remove customers to cart, it's not sending a POST request to the promotions endpoint any more. (I remember it was sending well before). I followed all steps according to the doc.

I attached the extension setting of my app. All endpoints are correct (tested via Postman)

I can't find any helpful document and forums.

I contact the partner support team and the support person said that he is new to this and so can't help.

I found this which is very complaining.

https://community.shopify.com/c/shopify-apis-and-sdks/pos-cart-extension-broken-with-iphone-app/m-p/...

What am i wrong? Any advise, very thank you!

 

JasonWeber0_0-1643186852419.png

 

Replies 5 (5)

GrahamS
Shopify Staff (Retired)
193 37 54

Hey @JasonWeber0 ,

 

Just wanted to check in to see if you are continuing to encounter this issue, and if so, when you most recently tested it? We can check the logs to see what might be happening in the backend.

To learn more visit the Shopify Help Center or the Community Blog.

JasonWeber0
Shopify Partner
9 0 0

I got it fixed.

Thank you

vernandoRGN
New Member
4 0 0

Hi Jason, may I know how did you fix it?

vernandoRGN
New Member
4 0 0

For future notes, turns out each time you restart the server you need to re-save /manage_extensions/point_of_sale/pos_cart_promotion settings as the ngrok URL is changed, shouldn't be a problem if you have a fixed URL.
Now, it's working.

vernandoRGN
New Member
4 0 0

Hi Graham, 

I got the same issue, I tried to add/remove customers but never get any request from Shopify, no request at all in the server log. I'm using Android Shopify POS. Could you help to check?