Deploying an App using Shopify CLI not working

Zipacna
Excursionist
12 1 3

Hello I am trying to deploy an app using the shopify CLI however it's not working.

I create a new folder.

I run shopify create to make a node app.

Then I run shopify generate billing to create a test recurring billing.

Then I run shopify deploy heroku and after I deploy the app I get a 500 internal server error. Its know its routing correctly:

"https://example.herokuapp.com/auth/inline?shop=example.myshopify.com"

 

It works fine when I use shopify serve to run it locally using ngrok: I get to the accept test charge page.

"https://example.ngrok.io/auth/inline?shop=example.myshopify.com"

 

Anyone ever experience this? I've deployed an app on heroku before but this is my first time using the CLI to do so.  I think something with the billing code is messing with it.

Thank you so much I'm on my last steps to finally try to get an app on the store! And this is frustrating!

 

Edit: I tried it without generating billing and it's still not working! I might be missing some line of code??

Reply 1 (1)

Kevin_A
Shopify Staff
318 42 61

Hey @Zipacna 

Can you confirm what version of Shopify CLI you are using? If you type shopify version in console, it should print this information out. If you are on 1.4.1 can you please try updating to the latest version? For reference:

https://shopify.github.io/shopify-app-cli/getting-started/upgrade/

Kevin_A | Solutions Engineer @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit Shopify.dev or the Shopify Web Design and Development Blog