Error when loading/authenticating app from ngrok url (shopify-cli)

Error when loading/authenticating app from ngrok url (shopify-cli)

12 1 4

I encountered an issue a couple of hours ago and still haven't found a solution.

I had a built an app with shopify-cli and have been using the 'shopify serve' command to run it on ngrok for development, which was been working for me for the past 2 weeks. Earlier today, while I was doing some work, I stopped the server so I could install a package. But when I restarted the server, my app simply wouldn't load anymore and would get stuck at the authentication page with the ngrok url as the address.

On my terminal, I receive the '[Network error]: Error: only absolute urls are supported' error, and on the console, I get anywhere between 1 to 3 errors that say "Failed to load resource: net::ERR_HTTP2_PROTOCOL_ERROR"

I've tried reverting all the changes that I made, and I'm confident that the app was still working at this state before, but it just stops at authenticating and won't load anymore. I've tried clearing my browser cache, switching to a different browser (tried out Firefox, originally on Chrome), signing up to ngrok and using the accesstoken there, and even restarting my pc among other attempts, but the app still won't load and would always get stuck in the ngrok url with a white screen.

If anyone has any suggestions or solutions to this problem I am all ears; I've tried searching the above errors in Google but I couldn't find a solution that fit my situation. And to be clear, all of the server code was autogenerated by shopify-cli, and they were working before. Nothing has changed other than I can't open my app anymore when I host it.

Replies 2 (2)

8 1 1

Hi @MilesLawrence, DId you find what was the issue here? 

I am having the exact same problem now. 

Shopify Partner
13 0 4

Any updates ?