[LoadError] cannot load such file --json

kJe-
Shopify Partner
1 0 0

[Note] You cannot use gems with Shopify CLI.
[LoadError] cannot load such file -- json
They are disabled.
Please don't modify the CLI locally.
If you would like to contribute to the CLI project, please refer to
https://github.com/Shopify/shopify-cli/blob/main/.github/CONTRIBUTING.md

[Note] You cannot use gems with Shopify CLI.
[LoadError] cannot load such file -- json
They are disabled.
Please don't modify the CLI locally.
If you would like to contribute to the CLI project, please refer to
https://github.com/Shopify/shopify-cli/blob/main/.github/CONTRIBUTING.md

[Note] You cannot use gems with Shopify CLI.
[LoadError] cannot load such file -- json
They are disabled.
Please don't modify the CLI locally.
If you would like to contribute to the CLI project, please refer to
https://github.com/Shopify/shopify-cli/blob/main/.github/CONTRIBUTING.md

<internal:/usr/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:37:in `require': cannot load such file -- json (LoadError)
from <internal:/usr/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
from /home/moro/Documents/Codespring/Repos/Kubuk/Shopify/recommend-similar-products/node_modules/@shopify/cli-kit/assets/cli-ruby/bin/shopify:15:in `require'
from /home/moro/Documents/Codespring/Repos/Kubuk/Shopify/recommend-similar-products/node_modules/@shopify/cli-kit/assets/cli-ruby/lib/shopify_cli/context.rb:6:in `<top (required)>'
from <internal:/usr/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
from <internal:/usr/lib/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:37:in `require'
from /home/moro/Documents/Codespring/Repos/Kubuk/Shopify/recommend-similar-products/node_modules/@shopify/cli-kit/assets/cli-ruby/bin/shopify:15:in `require'
from /home/moro/Documents/Codespring/Repos/Kubuk/Shopify/recommend-similar-products/node_modules/@shopify/cli-kit/assets/cli-ruby/lib/shopify_cli.rb:133:in `<module:ShopifyCLI>'
from /home/moro/Documents/Codespring/Repos/Kubuk/Shopify/recommend-similar-products/node_modules/@shopify/cli-kit/assets/cli-ruby/lib/shopify_cli.rb:42:in `<top (required)>'

 

I am developing an app for a store, and when I updated npm and tried running it I kept getting these error. I tried updating json with gem, removed versions, I still have installed 2.7.2 and 2.6.3, but when trying to switch it says I have no json installed. What can I do ?

Replies 0 (0)