OAuth - There's no page at this address

Oligi
Visitor
3 0 2

Hi,

 

I'm having a strange issue with the OAuth process.

I have implemented the installation process following the official guide. Until a few days ago, everything was working perfectly.

 

Now, during the OAuth process, after the user clicks "install app", the callback (redirect_url) is not called, but an error message is displayed: "There's no page at this address".

error.png

 

If I reload the page, everything works.

 

Can you help me? Have there been any recent breaking changes in the OAuth process? Can this be a UI bug?

Replies 11 (11)

lizk
Shopify Staff
246 57 70

Hi there! 

This was due to a production incident. This should now be resolved. 🙂

To learn more visit the Shopify Help Center or the Community Blog.

dan003400
Shopify Partner
4 0 2

@lizk We are still seeing this exact same issue, I do not believe this issue has been resolved.

 

@Oligi are you still seeing this issue?

KisukaKiza
Shopify Partner
38 0 33

My app suddenly has been getting this issue too. I have many clients mad at me for it even though it's not my app's bug. Please look into this again. I haven't changed anything in my app's oauth process and it was working perfectly until about May 3rd.

dan003400
Shopify Partner
4 0 2

We are in the same situation and there is nothing we can do, it appears this issue has not been resolved.

awwdam
Shopify Staff
249 42 36

Hi everyone!

Additional reports related to this incident were flagged, investigated, and our developers will be pushing out a fix momentarily.

Thank you for circling back to notify us, and for your patience.

- Best.



awwdam | API Support @ Shopify
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

KisukaKiza
Shopify Partner
38 0 33

Thanks @awwdam appreciate the fast action on this one.

dan003400
Shopify Partner
4 0 2

Thanks @awwdam - Looking forward to the resolution 🤞🏻

 

How can we track this issue? I am not seeing any issues documented on your status page....

 

https://www.shopifystatus.com/

GrizzleBear
Shopify Partner
2 0 0

Thanks @awwdam, we're developing our first app.  We just finished the OAuth video and everything was going great until the last step, where we are also seeing this error.  Has the fix been pushed or are the devs still working on this?

Side note, reloading does not fix this issue for us.

Thank you!

h_miniz
Shopify Partner
4 1 2

Not sure why, but we have received this feedback from Apps Review team with our new submitted app, even though we cannot reproduce issue in our side. Also we do not use Shopify CLI 😐

h_miniz
Shopify Partner
4 1 2

In the recent changelog, the new Shopify admin domain where all embedded apps will be available on admin.shopify.com.

 

However, according to embedded OAuth, apps must redirect using the host parameter - https://shopify.dev/apps/auth/oauth/getting-started#step-6-redirect-to-the-embedded-app-url. The host parameter is of the format host.myshopify.com.

 

Should we redirect to admin.shopify.com during OAuth flow now?

seunoyebode
Shopify Partner
11 0 0

How did you ever solve this issue ? @h_miniz