Shopify CLI can't login

Shopify CLI can't login

tt11
Shopify Partner
1 0 1

Hi all,

I'm having an issue logging into my store. This is the first time I'm attempting this.
When running shopify login --store={myStoreName}.myshopify.com I get this error:

 

 

✗ An unexpected error occured.
	To submit an issue include the stack trace.
	To print the stack trace, add the environment variable SHOPIFY_CLI_STACKTRACE=1.

** [Bugsnag] 2022-03-16 14:23:24 +0100: Unable to send information to Bugsnag (https://notify.bugsnag.com), #<OpenSSL::SSL::SSLError: SSL_connect returned=1 errno=0 state=error: certificate verify failed (unable to get local issuer certificate)>
** [Bugsnag] 2022-03-16 14:23:24 +0100: ["/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/protocol.rb:46:in `connect_nonblock'", "/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/protocol.rb:46:in `ssl_socket_connect'", "/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/http.rb:1038:in `connect'", "/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/http.rb:970:in `do_start'", "/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/http.rb:959:in `start'", "/Users/Tea/.rvm/rubies/ruby-3.0.0/lib/ruby/3.0.0/net/http.rb:1512:in `request'", "/Users/Tea/.rvm/gems/ruby-3.0.0/gems/bugsnag-6.24.2/lib/bugsnag/delivery/synchronous.rb:51:in `request'", "/Users/Tea/.rvm/gems/ruby-3.0.0/gems/bugsnag-6.24.2/lib/bugsnag/delivery/synchronous.rb:12:in `deliver'", "/Users/Tea/.rvm/gems/ruby-3.0.0/gems/bugsnag-6.24.2/lib/bugsnag/delivery/thread_queue.rb:38:in `block in serialize_and_deliver'", "/Users/Tea/.rvm/gems/ruby-3.0.0/gems/bugsnag-6.24.2/lib/bugsnag/delivery/thread_queue.rb:55:in `block (2 levels) in start_once!'"]

 

 


I've tried reinstalling everything, researching about OpenSSL certificates, shopify CLI info, and following countless tutorials to what I think might be the problem and I just end up with the same error every time. 
I'm using a mac.
Anyone encounter this before or could you point me to something that could help? Thank you so much.

Reply 1 (1)

csam
Shopify Staff (Retired)
267 40 51

Hi @tt11 

 

Thanks for reaching out. This looks similar to a couple of issues I found on the CLI github issues page - https://github.com/Shopify/shopify-cli/issues/2065

and 

https://github.com/Shopify/shopify-cli/issues/1673 

 

 

I believe we do support Ruby 3.0, however you might want to try a lower version. I would also recommend making sure all your gems are up to date. If you're still experiencing the issue, please post a new issue to https://github.com/Shopify/shopify-cli/issues 

 

Thanks!

To learn more visit the Shopify Help Center or the Community Blog.