Shopify CLI Stuck on "[nodemon] starting 'node serve/index.js'"

Shopify CLI Stuck on "[nodemon] starting 'node serve/index.js'"

Brayden2
Shopify Partner
2 0 0

Recently I've dabbling with the Shopify CLI and have consistently encountered the following issue. After creating an app through the given commands and trying the "shopify app serve" command, it freezes and fails to complete. With no error messages, I wasn't able to figure out a solution myself and was hoping to see if anyone else had a solution.

 

Brayden2_0-1659054381333.png

 

Versions:

Shopify-cli: 2.20.1

Node.js: v16.16.0

Ruby: 3.1.2

Replies 3 (3)

Alan
Shopify Staff
129 15 24

Hey @Brayden2 - thanks for sharing this, definitely weird. I wasn't able to replicate the error on my end. 

A few general tips though, if you have tried them already are to uninstall and then re-install the CLI itself to see if it resolves the issue. The good thing about this, if you're using something like Brew to manage dependencies is that it would automatically update these as well if required. 

If you've already done this and the issue still persists - no worries. The next thing to check is to see if you're able to create a test app using the "shopify app create" command and see if you're able to install that through the link provided in the CLI ( if you have something like a ngrok tunnel set-up) to see if it will install that way. 


Let me know if you've already given those two steps a try or if you do go ahead and try those and the error persists - happy to to keep digging into this with you. 

Alan | API Support @ Shopify
- Was my reply helpful? Click Like to let me know!
- Was your question answered? Mark it as an Accepted Solution
- To learn more visit Shopify.dev or the Shopify Web Design and Development Blog

Brayden2
Shopify Partner
2 0 0

Thank you for the prompt response!

 

I've already tried reinstalling shopify-cli and it seems that everything is up to date. In addition, the app I've created was through the provided templates, and seems to be working fine. The main issue from what I can tell is that the cli isn't able to create a tunnel despite it saying so. On my ngrok account, it doesn't display a tunnel when executing the 'shopify app serve' command, which is in contrast to when I create a tunnel directly through ngrok.exe.

 

As things stand, I am incredibly unfamiliar with tunnels and have no clue how to complete the process manually. So, if it were possible to do so, are there any online resources which could explain how?

Bonushunting
Shopify Partner
1 0 0

Hello Brayden2, have you solved your problem? I am experiencing precisely the same and having troubles. Do you mind taking a moment to explain the solution i.e. if you have solved it - it would also be much appreciated if you replied if you havent solved it?