Shopify CLI Version Freezes

Shopify CLI Version Freezes

scole954387
Shopify Partner
20 1 10

Hi,

 

I stepped away from shopify CLI to learn more react and went back today to create a new app using the CLI.    When I ran Shopify I was prompted that a new version was available.  I used the "gem update shopify-cli" and it appeared to be successful however now when I attempt to run any Shopify command it just freezes and does nothing else.

 

Even if I try Shopify Version it just hangs.

 

I've restarted the computer.  Uninstalled and reinstalled shopify-cli again.  

 

Any ideas what might be causing it to hang?  

 

I'm thinking of uninstalling everything (react, node, npm, etc) and starting from scratch again.

 

Update:  Ok, now this is ODD.  If I run "Shopify Version" from any folder in C: it freezes however if I run it on 😧 (second hard drive) is works.  I've never had something in environment variables only work on a specific drive.    Any thoughts?

 

Update 2:  Ok, so now I'm able to get it to run on C: by running command prompt as administrator.  I can run it on 😧 without admin rights but to run it on C drive I have to launch it with admin.  Very unusual.

 

Replies 0 (0)