Solved

Additional payment methods icons on cart page

Katekorn
Visitor
2 0 0

Hi there,

we are on Imact Theme

On Cart page it has section We accept under Checkout button which shows main payment methods icons

As we have additional payment methods (Afterpay etc.) i wonder how to add it's icons there.

We added them to footer but no luck with this Cart page section and it seems to be weird having mismatch.

Katekorn_0-1709069063654.png

 

 

Accepted Solution (1)

PageFly-Richard
Shopify Partner
4206 951 1599

This is an accepted solution.

Hi @Katekorn 

 

This is Richard from PageFly - Shopify Page Builder App

 

You will need to enable those payment methods, and after that you can add this code and where you want it to show in cart page

<ul class="list list-payment" role="list" style="margin-top:10px;">
       {% assign enabled_payment_types = 'ideal,visa,maestro,master,american_express,bancontact' | remove: ' ' | split: ',' %}
       {% for type in enabled_payment_types %}
          <li class="list-payment__item">
             {{ type | payment_type_svg_tag: class: 'icon icon--full-color' }}
          </li>
       {%- endfor -%}
</ul>

You can try the main-cart.liquid file.

 

Hope this can help you solve the issue 

 

Best regards,

Richard | PageFly

Please let me know if it works by giving it a Like or marking it as a solution!


PageFly - #1 Page Builder for Shopify merchants.


All features are available from Free plan. Live Chat Support is available 24/7.

View solution in original post

Replies 3 (3)

PageFly-Richard
Shopify Partner
4206 951 1599

This is an accepted solution.

Hi @Katekorn 

 

This is Richard from PageFly - Shopify Page Builder App

 

You will need to enable those payment methods, and after that you can add this code and where you want it to show in cart page

<ul class="list list-payment" role="list" style="margin-top:10px;">
       {% assign enabled_payment_types = 'ideal,visa,maestro,master,american_express,bancontact' | remove: ' ' | split: ',' %}
       {% for type in enabled_payment_types %}
          <li class="list-payment__item">
             {{ type | payment_type_svg_tag: class: 'icon icon--full-color' }}
          </li>
       {%- endfor -%}
</ul>

You can try the main-cart.liquid file.

 

Hope this can help you solve the issue 

 

Best regards,

Richard | PageFly

Please let me know if it works by giving it a Like or marking it as a solution!


PageFly - #1 Page Builder for Shopify merchants.


All features are available from Free plan. Live Chat Support is available 24/7.

Katekorn
Visitor
2 0 0

Thanks Richard, 
I ended up adding part of code you provided:

{% assign enabled_payment_types = 'visa,master,jcb,afterpay,poli' | remove: ' ' | split: ',' %}
So it looks like that now:
<div class="h-stack gap-2 wrap justify-center">
{% assign enabled_payment_types = 'visa,master,jcb,afterpay,poli' | remove: ' ' | split: ',' %}
{% for type in enabled_payment_types %}
{{- type | payment_type_svg_tag -}}
{%- endfor -%}
</div>

    

works fine, thanks for your help!

PageFly-Richard
Shopify Partner
4206 951 1599

Glad that i can help 

Please let me know if it works by giving it a Like or marking it as a solution!


PageFly - #1 Page Builder for Shopify merchants.


All features are available from Free plan. Live Chat Support is available 24/7.