Solved

Color swatch not visible in another language

frede-1994
Shopify Partner
3 0 4

Hi,
I am using the Impact theme.
I configured color swatches in the theme settings like the following:

 

Chrome:#D3D1CC
Chrome/White:#F8F9F9
White:#F8F9F9
Grey:#A6ACAF

 

 

After doing that i configured the variant picker on the product page to use style "Swatch" and it works for my default language (english). When switching to another language (norwegian), my variant picker changes to style "None" showing the color names instead. I would like it to also use swatches.

 

If I switch language in the theme editor, it tells me to use the translate and adapt app to translate my site. I translated my swatches like this:

Screenshot 2024-04-17 at 09.08.32.png
But it still just shows the color names and not the swatches.
What am I doing wrong? 

Accepted Solution (1)

tim
Shopify Expert
3469 280 1286

This is an accepted solution.

Have you tried to input color rules for all translations into theme setting?

Like:

Chrome:#D3D1CC
Forkrommet:#D3D1CC
 ...

 

Also check this https://prestige-theme.helpscoutdocs.com/article/417-configuring-color-swatches#Configuring-the-opti... 

to ensure that your color option name is recognized as color swatch type when translated.

If my post is helpful, consider liking it -- it will help others with similar problem to find a solution.
I can be reached via e-mail tairli@yahoo.com

View solution in original post

Replies 2 (2)

tim
Shopify Expert
3469 280 1286

This is an accepted solution.

Have you tried to input color rules for all translations into theme setting?

Like:

Chrome:#D3D1CC
Forkrommet:#D3D1CC
 ...

 

Also check this https://prestige-theme.helpscoutdocs.com/article/417-configuring-color-swatches#Configuring-the-opti... 

to ensure that your color option name is recognized as color swatch type when translated.

If my post is helpful, consider liking it -- it will help others with similar problem to find a solution.
I can be reached via e-mail tairli@yahoo.com
frede-1994
Shopify Partner
3 0 4

Hi Tim, thanks for the answer!
I was missing the translation of my color option. It was called "Color" on both my english and norwegian site. After translating it, my swatches showed up.

I had the translations for the colors in the theme settings as well, even though I disliked it since it means duplicated hex-values and duplicated color translations. After it worked, I tried removing the translate-and-adapt values for the swatch, and it still works, so I guess I will just have my color translations in the theme settings.