Solved

Having a problem with my page title!

übermensch
Excursionist
17 1 1

Hi there,

 

I'm trying to fix a problem I'm having at the moment with my homepage tiltle. The title that's been indexed on Google is NOT the same as the one I've set up on the homepage title on preference section on Shopify.

 

Regardless of the title, there's always an extra line (store name / website name) appears automatically in front of the title, so it's something like this: The store name: title - I just want to get rid of "store name:" does anyone know how to fix this? Thanks a lot.

Accepted Solution (1)
übermensch
Excursionist
17 1 1

This is an accepted solution.

Hi there, thanks for the reply.

 

I've fixed the problem already, than you.

View solution in original post

Replies 6 (6)

Jack_Khan_Baba
Shopify Partner
90 8 14

could you share the screen shot

Please don't forget to Like and Mark Solution to the post that helped you. Thanks!
Chat on WhatsApp: +923143054166
Need a Shopify developer? Hire us at naimatullahts335@gmail.com
- Hire me, if you want to design, re-design, develop a store, or make changes to the pre-built store.
übermensch
Excursionist
17 1 1

Thanks for your reply.

 

There's no screen shot, here's our URL: https://kwiketo.com and in the title section we have Kwiketo: Title and this bit (Kwiketo:) is unwanted and we did not add it and it has been added automatically and it's not showing in preference --> Homepage title in Shopify and we have no control over this so we can't remove it but it still appears in front of the title for the SEO, do you know how we can remove it?

BSS-TechFusion
Shopify Expert
149 26 15

Hi @übermensch .

I guess your theme use Logo in header and that is an image, you can't  change text in there 
For example in my test store, i set up my logo.

 

BSSTechFusion_6-1714809629221.png

 

 

Now if you want to delete This logo in your store

 
 
 

BSSTechFusion_9-1714809648159.png

 


You can check in theme customize and remove logo

Step 1 :

In theme , click customize

 

BSSTechFusion_10-1714809671362.png

 

 

Step 2 : Choose header , find theme setting 

 

BSSTechFusion_11-1714809683987.png

 

BSSTechFusion_12-1714809711033.png

 

Now the store'name is appear

 

BSSTechFusion_13-1714809724660.png

 

I hope these instructions will help you. If they are helpful, don't forget to like and mark as the solution.

 

If our suggestions are useful, please let us know by giving it a like or marking it as a solution.

For B2B solutions and custom pricing, check out B2B Wholesale Solution by BSS |
For adding product labels/badges, visit BSS: Product Labels & Badges

BSS Commerce - Shopify Apps & Store Development Service Provider

Hire a Shopify expert | Shopify Plus Store Development

übermensch
Excursionist
17 1 1

Hi there, thank you for the reply.

 

I can't delete the logo obviously and I guess it doesn't have to do with the logo because the logo has been there before I have this issue with the homepage title.

BSS-TechFusion
Shopify Expert
149 26 15

Hi @übermensch , You can try to follow my instructions.

  • Go to Online Store -> Theme -> Actions -> Edit code 
  • Go to Layout folder -> theme.liquid file 
  • Look for the "<title>" tag in the head section of the code.
    Change the text between the "<title>" and "</title>" tags to the title you want to appear on the Google page. You can adjust the title section similar to the image below to retain only the page title.
 <title>
      {{ page_title }}
 </title>
  • Save and test

I hope these instructions will help you. If they are helpful, don't forget to like and mark as the solution.

If our suggestions are useful, please let us know by giving it a like or marking it as a solution.

For B2B solutions and custom pricing, check out B2B Wholesale Solution by BSS |
For adding product labels/badges, visit BSS: Product Labels & Badges

BSS Commerce - Shopify Apps & Store Development Service Provider

Hire a Shopify expert | Shopify Plus Store Development

übermensch
Excursionist
17 1 1

This is an accepted solution.

Hi there, thanks for the reply.

 

I've fixed the problem already, than you.