How to remove an old language switcher from my website?

alex86ander
New Member
4 0 0

Hello,

I've changed translation apps, but the old language switcher is still visible in the bottom right corner.

I did find the following code in theme.liquid, 

<!-- langify-v2-scripts-begin -->{% comment %}ly_liquid_scripts_begin{% endcomment %}{% endcapture %}{% render 'ly-liquid-scripts' content: ly_liquid_content %}{% comment %}ly_liquid_scripts_end{% endcomment %}{% comment %}ly_core_scripts_begin{% endcomment %}{% render 'ly-core-scripts' %}{% comment %}ly_core_scripts_end{% endcomment %}{% comment %}ly_switcher_factory_begin{% endcomment %}{% render 'ly-switcher-factory' %}{% comment %}ly_switcher_factory_end{% endcomment %}<!-- langify-v2-scripts-end --></body>

 

But when I try to remove it I get this error message

  • Line 270 — Liquid syntax error: 'capture' tag was never closed

Can anyone help remove the switcher?

URL is www.revivalaccessories.com

Replies 6 (6)

Zworthkey
Shopify Partner
5581 642 1572

@alex86ander let me check out what issues are occuring.
thank you

Zworthkey
Shopify Partner
5581 642 1572

@alex86ander Hi, we have to check out your site, you needs to custom code or need to check out the particular file section of yourstheme.
Thank you.

faia-place
Visitor
1 0 0

Hey Alexander, 

were you able to fix the problem with the langify language switcher? We would be very interested if there was a solution, as we run into the same error message. 

BR Dominic 

alex86ander
New Member
4 0 0

I never found a solution. I just ended up reinstalling the theme again

Zaimoen
Visitor
1 0 0

I have the same problem, but when I deleted 'ly-switcher-factory.liquid', it disappeared.

michaelivanov
Shopify Partner
34 5 10

Hi @alex86ander,

Michael from Langify here.

 

In the current Langify version, it suffices to simply disable Langify in Shopify's App Embeds section:

 

langify app embeds.png

 

However, if you want to hide the Language Switcher but want to keep using Langify on your store then you'd just have to go to 

 

Langify -> Dashboard -> Switcher Configurator 

 

and set the Language Switcher "Switcher Type" to "None" like

 

switcher type none.png

 

Note that you'd have to do the same for the mobile Language Switcher as well:

 

mobile switcher type nonw.png