invalid environment [development]: (invalid store domain must end in '.myshopify.com')

Yehor
Visitor
1 0 2

Hi, I am trying to install the themekit using the manual: http://prntscr.com/m71dwb 
But when using this command, an error occurs: http://prntscr.com/m71f3b 
What do i do?

Replies 23 (23)

Alex
Shopify Staff
1561 81 341

Hey Yehor,

This might be better suited to the design forums - this forum is meant to dsicuss Shopify's APIs and SDKs specific to said APIs. I'll move this thread.

Cheers.

Alex | Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Arthur_Korniyen
Shopify Expert
198 3 85

Hello Yehor,

There is no need to add square brackets - "[" and "]" when you put your data to this line:

theme get --password=[your-api-password] --store=[your-store.myshopify.com] --themeid=[your-theme-id]

 

You need to paste the following:

theme get --password=Your-api-password --store=Your-store.myshopify.com --themeid=Your-theme-id

 

Hope this helps.

Best regards,
Arthur

Founder at GenovaWebArt | info@genovawebart.com
Marvinho
Visitor
2 0 0

i have the same issue even i remove the bracket, the invalid store domain still exist.

mystore : alpha-living-2.myshopify.com

Marvinho
Visitor
2 0 0

sorry, i think i found the solution, it's the invalid environment issue 

aquasar
Shopify Partner
32 2 4

Hello I am having some problem. What is the invalid environment issue?

 

Thanks

MrHahn
Shopify Partner
2 0 13

I'm not sure if this will help anyone, but i was having this issue, while trying to grab my theme id using the --list command, i noticed that the shorthand for store, -s, didn't work, i had to use all the long commands so --password  and --store instead of -p or -s. not sure why it worked one way and not the other but that was the trick for me

DeclanD
Visitor
1 0 1

This resolved it for me

yori
Shopify Partner
24 1 3

it solved the issue for me too

I wonder why 

theme get --list -p=[your-password] -s=[you-store.myshopify.com]

couldn't work

appsius
Shopify Partner
31 0 2

 --password  and --store instead of -p or -s solved the issue.

Apoddar
Visitor
1 0 0

Nahh still seems like a problem for me, I dunno what's wrong

Levi5
Tourist
5 0 13

I also have this same issue. --password and --store does not work

Edit: Oh! duh. Don't use the brackets ha

johnuwp
Shopify Partner
5 0 2

This is what I worked out before finding this, can confirm --store --password and --themeid works but -s -p -t does not.

Sergio_2093
Visitor
1 0 0

este blog de discusion se que me ha servido.... muchas gracias por sus comentarios de ayuda

Bobannbg
Visitor
1 0 0

This worked for me. Thanks a lot! (so, "-p" flag worked but "-s" had to be replaced with "--store") 

Louis16
Visitor
1 0 0

couldn't work。my answer is 

theme get --list -p=your-password -s="your-sotrename"

Quotation marks for your-name,it works

vendors
Excursionist
11 0 5

What I have to use if my shopify url is not ends with .myshopify.com

HAM3
Shopify Partner
3 0 0

Where do you find the API password ?

 

vasanth0791
Tourist
11 0 3

Hello All,

Here is the solution for theme kit is working for my local.

Try,

theme get -p=shppb_c6f0a508c6961129f776aefdf549f2f9 -s="likemystore.myshopify.com" -t=83355992111

Replace your store name between the quotes.

Thanks,

Vasanth

 

 

 

 

Shopify Expert | Freelancer
Skype id: vasanth0791 | mail: due07vasanth@gmail.com
medquality
Visitor
1 0 1

* attention: not only change from shorhand to long commands, but don't forget double dash -- instead od singles - in front of command

Deus
Visitor
1 0 0

This is the right answer \m/ Just replace the theme id as string (i.e. my-theme-name) with the numerical ID (i.e. 121858954458) you get when you use --list suffix.

Kenny_Greenbox
Shopify Partner
2 0 0

I was getting the same issue. I fixed the issue by updating my version of ThemeKit from 1.1.6 to latest. 

I was trying to connect using the ThemeKit app and following their instructions by generating an account and using the password it emails you. If I created the private app I could connect by manually creating the 'config.yml' file but was getting an error if I tried using the 'theme get' method described in the instructions. After updating ThemeKit my issues went away.

shreyjain
Shopify Partner
1 0 0

Not sure whether relevant today or not. But you can try this. 

theme new --password=shptka_6e7d85eea2f31de1fa9ef4bc91bc6c10 --store= bootstap-store.myshopify.com  --name=nameNotNeccessary 

 

moromidesign
Tourist
8 0 5

I was able to use this in terminal and it solved the issues I was having:

theme get --list --password="thepasswordhere" --store="store.myshopify.com"
Isa Stewart @ Moromi Design