Meta field file not getting linked to website body.

Hallmark930
Tourist
6 0 1

I set up a meta field using "file" as my type.

I selected "all files".  It is a PDF file.

But when I go to add it to my page using "connect dynamic source" icon 

from the custom view of the web page theme that filename does even list with the other meta fields.

Why is this?

I even tried it both with the Trade theme and Enterprise theme.

But with other 

The help center expert could not even figure it out.

 

 

Replies 6 (6)

theyCallmepro
Shopify Partner
27 0 4

Hello @Hallmark930 


Can you please share page link and customization Screenshot so i can check.

Hallmark930
Tourist
6 0 1

 

 

Screen shot 510.png

 

Screenshot 510a.png

 

 

theyCallmepro
Shopify Partner
27 0 4

@Hallmark930 

You have created metafield with file format so you need to add image_picker settings in customizer then you can able to add files here.

If you require further help to optimize your store, please don’t hesitate to reach out. If you find this information useful, a Like would be greatly appreciated. And if this solves the problem, please Mark it as Solution!

Hallmark930
Tourist
6 0 1

It is not an image.  The file is in PDF format.

Does that make a difference?

Hallmark930
Tourist
6 0 1

Thanks for the quick response.

I am new to using Shopify and my company

is having me set up our new site (used to run Drupal).

 

 

theyCallmepro
Shopify Partner
27 0 4

@Hallmark930 If you are new to Shopify you need assistance for setup your store. I am there for you.