Solved

Payment icons are not displayed (seems like something is wrong in code)

Warbound
New Member
4 0 0

Hello guys, a starter here. 

Currently I'm struggling with code to add payment methods to my footer page. Basically I went on and found a code that i needed to replace. Which was this one: 

{% for type in shop.enabled_payment_types %}

Replaced it with: {% assign enabled_payment_types = 'visa,master,american_express,paypal,google_pay,apple_pay,diners_club,discover' | remove: ' ' | split: ',' %} {% for type in enabled_payment_types %}

And it applied to my code, but still is not showing the payment methods within the footer line. 

I would greatly appreciate if someone has a solution to my problem! 

Thanks in advance guys!

Accepted Solution (1)
MarcoReleasit
Shopify Partner
314 24 63

This is an accepted solution.

Ok

At the very top of the footer.liquid template you should find this piece of code:

{%- assign social_icons = false -%}
{%- assign inline_list = false -%}
{%- assign locale_selector = false -%}
{%- assign country_selector = false -%}
{%- assign show_payment_icons = false -%}
{%- assign show_selectors = false -%}

Change the {%- assign show_payment_icons = false -%} to {%- assign show_payment_icons = true -%} and see if this solves it.

If you still can't see the icons I ask you to paste here all the code in your footer.liquid template, because from the code I see on the screeshot everything is correct!

Let me know if this works!

Marco

Install Releasit Cash On Delivery for free here: https://apps.shopify.com/cash-on-delivery-fee
Add a fee to Cash on Delivery and limit COD based on any condition (order total, location, products, collections, etc.)

View solution in original post

Replies 10 (10)

MarcoReleasit
Shopify Partner
314 24 63

Hi Warbound!

Can you share all the code in your footer template where you replaced the code?

Install Releasit Cash On Delivery for free here: https://apps.shopify.com/cash-on-delivery-fee
Add a fee to Cash on Delivery and limit COD based on any condition (order total, location, products, collections, etc.)
Warbound
New Member
4 0 0

codee.png

Here you go, this is for Debut theme if it helps. 

MarcoReleasit
Shopify Partner
314 24 63

Thanks for the code!

The code you replaced is correct.

Have you enabled the setting on the theme editor to show the payment icons?

MarcoReleasit_0-1626628106499.png

If you do not activate the setting on the editor then the icons will not show up on your footer. To enable it open the theme editor by going to Online Store -> Customize (on the Debut theme) then click on the footer section and you will see the settings in the screenshot above.

Let me know if this helps!

Install Releasit Cash On Delivery for free here: https://apps.shopify.com/cash-on-delivery-fee
Add a fee to Cash on Delivery and limit COD based on any condition (order total, location, products, collections, etc.)
Warbound
New Member
4 0 0

It is enabled, forgot to mention that, apologies.

What else could be the problem?

MarcoReleasit
Shopify Partner
314 24 63

This is an accepted solution.

Ok

At the very top of the footer.liquid template you should find this piece of code:

{%- assign social_icons = false -%}
{%- assign inline_list = false -%}
{%- assign locale_selector = false -%}
{%- assign country_selector = false -%}
{%- assign show_payment_icons = false -%}
{%- assign show_selectors = false -%}

Change the {%- assign show_payment_icons = false -%} to {%- assign show_payment_icons = true -%} and see if this solves it.

If you still can't see the icons I ask you to paste here all the code in your footer.liquid template, because from the code I see on the screeshot everything is correct!

Let me know if this works!

Marco

Install Releasit Cash On Delivery for free here: https://apps.shopify.com/cash-on-delivery-fee
Add a fee to Cash on Delivery and limit COD based on any condition (order total, location, products, collections, etc.)
Warbound
New Member
4 0 0

It works!

Thanks alot, really appreciate you!

Best Regards Warbound

YMTE
Tourist
14 0 2

Hi. This didn't work for me. None of this is showing at the top of the footer.liquid

I have Payment Methods enabled, but don't see the option to change its colors. The theme I'm using is Minimal. Please help.

farid1994
Tourist
10 0 2

@MarcoReleasit Thanks, it worked for me as well but only in desktop version. For some reason my mobile version still doesn't show icons 😕 Could you maybe have a look at it? Thanks

 

lemonville.store

Pass: flowxe

MajaFraneMX
New Member
7 0 0

Hi Marco, 

 

I followed the instructions but still I have no icons displayed. For some reason, the only displayed icon is PayPal. Here is the code from Footer liquid. Thanks a bunch.

Shopify payment icons.png

 {% if section.settings.payment_icon_enable %}
{%- assign show_payment_icons = true -%}
<div class="payment-icon mt-40">
<ul class="list list-payment d-flex justify-content-end" role="list">
{%- for type in shop.enabled_payment_types -%}
<li class="list-payment__item">
{{ type | payment_type_svg_tag: class: 'icon icon--full-color' }}
</li>
{%- endfor -%}
</ul>
</div>
{% endif %}

Jewel
Shopify Partner
6 0 0

Add this code to the footer.liquid file. 

<div class="payment-methods">
<img src="{{ 'visa.png' | asset_url }}" alt="Visa">
<img src="{{ 'mastercard.png' | asset_url }}" alt="MasterCard">
<img src="{{ 'paypal.png' | asset_url }}" alt="PayPal">
<img src="{{ 'american_express.png' | asset_url }}" alt="American Express">
<!-- Add more logos as needed -->
</div>

 

Like this , Add the payment icon link on the <img src=https://cdn.shopify.com/s/files/1/0807/6342/0964/files/payments.png?v=1715017547

Jewel