Remove play bar and controls from homepage video

Solved
hlyarndt
New Member
4 0 0

I have the code below posted as Custom Liquid section on my homepage. I use the free theme Craft. Can someone share what I can add to remove the control bars that show up when you hover over the video? The play bar, sound, expand, etc.

 

<video style="max-width: 100%; height: auto;" controls muted playsinline autoplay loop>
<source src="https://cdn.shopify.com/videos/c/o/v/14d4d950d0ab42228c3cdb470cb76bf6.mp4" type="video/mp4">
</video>

 

Website is strayfolkgoods.com 

Accepted Solution (1)
Ninthony
Shopify Partner
2319 349 1012

This is an accepted solution.

Remove the controls attribute from the video 

 

<video style="max-width: 100%; height: auto;" muted playsinline autoplay loop>
<source src="https://cdn.shopify.com/videos/c/o/v/14d4d950d0ab42228c3cdb470cb76bf6.mp4" type="video/mp4">
</video>
If my solution helped you, please like it and accept it as the solution!
If you'd like to make any edits to your store, please send me a personal message and we can discuss what you'd like to accomplish 😄

View solution in original post

Replies 4 (4)
Ninthony
Shopify Partner
2319 349 1012

This is an accepted solution.

Remove the controls attribute from the video 

 

<video style="max-width: 100%; height: auto;" muted playsinline autoplay loop>
<source src="https://cdn.shopify.com/videos/c/o/v/14d4d950d0ab42228c3cdb470cb76bf6.mp4" type="video/mp4">
</video>
If my solution helped you, please like it and accept it as the solution!
If you'd like to make any edits to your store, please send me a personal message and we can discuss what you'd like to accomplish 😄
hlyarndt
New Member
4 0 0

Thank you! This worked great for desktop but now on mobile it's not autoplaying! It has a big play button in the middle. Is there a workaround for that?

hlyarndt
New Member
4 0 0

Oh...strange! The play button is only showing sometimes. Do you know why that could be happening?

Ninthony
Shopify Partner
2319 349 1012

It shouldn't be. As long as it's muted, the autoplay attribute is set, and playsinline attribute is set for iOS it should be fine autoplaying on mobile.

If my solution helped you, please like it and accept it as the solution!
If you'd like to make any edits to your store, please send me a personal message and we can discuss what you'd like to accomplish 😄