Solved

Show color swatch on collection page instead of text

blakelyhi
Explorer
87 0 4

Hi, using Stiletto Theme and I want to show the circle product swatches as default instead of the word "3 colors", currently the circle swatches only appear on hover and I'd like for them to appear immediately and remove the text above it for all products..

URL: https://afca7f-2.myshopify.com/

 

Screenshot 2023-11-12 at 6.33.09 AM.png

Accepted Solutions (2)

fadi_yousif
Shopify Partner
342 43 60

This is an accepted solution.

To show the color swatches at all times, navigate to assets --> theme.css and remove opacity: 0; on line 9616.

 

To remove the text, you need to find and delete the <h5> element with a class of product-item__swatch-count. Another option would be to hide the element by adding the following code to the end of theme.css:

h5.ff-body.fs-body-50.product-item__swatch-count {
    display: none;
}

If the above doesn't work, try this:

h5.ff-body.fs-body-50.product-item__swatch-count {
    display: none !important;
}

 

View solution in original post

theycallmemakka
Shopify Partner
1158 249 269

This is an accepted solution.

Hi @blakelyhi ,

 

Follow these Steps:

1) Go to Online Store
2) Edit Code
3) Find theme.liquid file

4) Add the following code just above </body> tag

<style>
.product-item__variant-info, .product-item__variant-info{
    opacity: 1!important;
}
</style>

 

If you require further help to optimize your store, please don't hesitate to reach out. If you find this information useful, a Like would be greatly appreciated. And if this solves the problem, please Mark it as Solution!

 

Best Regards,
Makka

❤️❤️

Buy me a coffee


For quick response - Message Me


For easy store customization, try PageFly
Add Winter vibe to your store

View solution in original post

Replies 4 (4)

fadi_yousif
Shopify Partner
342 43 60

This is an accepted solution.

To show the color swatches at all times, navigate to assets --> theme.css and remove opacity: 0; on line 9616.

 

To remove the text, you need to find and delete the <h5> element with a class of product-item__swatch-count. Another option would be to hide the element by adding the following code to the end of theme.css:

h5.ff-body.fs-body-50.product-item__swatch-count {
    display: none;
}

If the above doesn't work, try this:

h5.ff-body.fs-body-50.product-item__swatch-count {
    display: none !important;
}

 

blakelyhi
Explorer
87 0 4

Thank you, the code worked beautifully but I'm not sure I'm locating the right line of code to remove the opacity... my 9616 line doesn't show anything like that. Would it be my line 9611? Attaching an image. 

 

Screenshot 2023-11-12 at 8.52.32 AM.png

fadi_yousif
Shopify Partner
342 43 60

Yes, line 9611 in your case! It was listed at 9616 in my browser.

theycallmemakka
Shopify Partner
1158 249 269

This is an accepted solution.

Hi @blakelyhi ,

 

Follow these Steps:

1) Go to Online Store
2) Edit Code
3) Find theme.liquid file

4) Add the following code just above </body> tag

<style>
.product-item__variant-info, .product-item__variant-info{
    opacity: 1!important;
}
</style>

 

If you require further help to optimize your store, please don't hesitate to reach out. If you find this information useful, a Like would be greatly appreciated. And if this solves the problem, please Mark it as Solution!

 

Best Regards,
Makka

❤️❤️

Buy me a coffee


For quick response - Message Me


For easy store customization, try PageFly
Add Winter vibe to your store