Solved

Social sharing image not working

kadamczyk
Visitor
1 0 0

I have uploaded an image in Preferences, but the image is blank when I try to post a link to my store on Facebook. If I link to any other page than the main address, I get an image, but not the main shop page.

Also, I have updated the Home Page Title and Meta Description, but these changes are not showing when I post a link.

The store is https://sdivadesigns.myshopify.com/

 

Accepted Solution (1)
Julie
Shopify Staff
1109 106 368

This is an accepted solution.

Hi @21MillionCo!

Thanks for letting me know that you've already tried using the Facebook Sharing Debugger. When you use the Facebook Sharing Debugger, Facebook will typically update this information immediately. If this isn't happening, then there may be another issue at hand.

To clarify, are you referring to your store logo or a product image? Also, when you share a link, do you see an outdated image or no image at all? 

Generally speaking, the image that appears when you share a link depends on the link itself; if you're sharing a product link, then the image that appears will be your product's featured image. If you're sharing a link to your store's homepage, then the image that appears should be your store logo. If your logo isn't appearing, then this could be a theme-related issue. 

Some themes actually have a social sharing image setting within them, which can be found in Online store > Themes > Customize > Theme settings. Do you see this option there? If so, the image uploaded there will always override the social sharing image you may have added in Online store > Preferences. If your theme does not have this setting, then the image used will be the one you've added in Preferences.

However, if you aren't seeing any image at all when you sharing a link, then this may be because you are sharing that particular link for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

I hope this clears things up, but if you are still experiencing the same issue, please let me know which link you're trying to share, along with the name of the theme you're using. With a bit more information, I'd be happy to do some further digging!

Looking forward to your response. 

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

View solution in original post

Replies 45 (45)

Julie
Shopify Staff
1109 106 368

Hi, @kadamczyk!

Julie here from Shopify Support.

Which theme are you using? Some themes offer you the ability to choose a social media image for your online store directly through the theme editor in Online store > Theme > Customize > Theme settings. If your theme offers this option, then the social media image you choose in your theme settings will override any social sharing image settings from Online store > Preferences.

Do you see an option to add a social media sharing image there? If so, then you will need to add the social media image through the theme editor.

However, if your theme does not offer the option through the theme editor, then it sounds like you may need to use the Facebook Sharing Debugger to refresh the information that is saved for your page links. Typically, it will take Facebook a few days to update this information, but the Facebook Sharing Debugger should speed up the process.

I hope this helps. Feel free to respond here and let me know which theme you're using and whether the Facebook Sharing Debugger does the trick.

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

batecolifestyle
Tourist
9 0 3

When I place a new image in for social media it's defaulting back to my logo - and logo is half chopped off when sharing link. I really want my image and not the logo but not working. Desperately need help

Julie
Shopify Staff
1109 106 368

Hey, @batecolifestyle!

Thanks for joining in on the conversation. It sounds like your social media sharing image has not yet been updated. As mentioned above, it can take Facebook a few days to update this information. However, using the Facebook Sharing Debugger should help speed up the process, as it will force a refresh. Have you tried doing so yet? 

As for your logo appearing to be "chopped off", it's likely that the image file you've selected for your logo doesn't meet Facebook's size requirements. If you are also experiencing the same problem with the new image you have uploaded, then you'll just need to ensure that your image is the correct size. Facebook actually has a help doc on images in link shares that outline these specifications. You can check that out here.

Once you give the Facebook Sharing Debugger a try, please let me know how that goes!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

w-works
Excursionist
15 0 10

My social sharing image is set up and working fine, BUT it was my understanding that was for general site social sharing (home page, blog, etc.) and not product-specific social sharing so, imagine my surprise when I tested social sharing of a product and it pulled in the default social sharing image instead of the product image from that product page.  This should be common coding on all Shopify themes (in this instance, using Boundless) as the main reason to use the Shopify platform is to sell products and, well, if you're sharing a product on social media, it would be a good think to actually have the image of the product shared.  Please advise a fix for this. Thanks! 

Julie
Shopify Staff
1109 106 368

Hey, @w-works!

I appreciate you joining the conversation.

You're right - Shopify's free themes, including Boundless, are designed to display the featured image for a page when you share that particular page link on social media; if you're posting a link to a product page, then the product image should appear as the featured image. 

That being said, the image that's used is also dependent on the social media platform you're sharing your link on. In the event that the social media platform cannot pull an image from the product page, then the image from Online store > Preferences will be used.

Which social media platform are you sharing your product links on? Do you have an example of a link that you can share with me? 

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

w-works
Excursionist
15 0 10

Just the standard three - Twitter, Facebook and Pinterest.  The site is currently locked with a password as we haven't yet launched, but the share doesn't work either in editor mode nor after having logged in - it keeps pulling the default site social image vs. the product image.    

Julie
Shopify Staff
1109 106 368

Thanks for the further information, @w-works!

With your storefront password enabled, this is expected behaviour, since external websites will only be able to pull information from the password page. Any content beyond that, including product pages, will remain hidden until the password is disabled. Once you remove the storefront password, you should notice your product images appear when you share product links.

Before you remove your password and launch your store, however, I suggest taking a look at our Essential Store Launch Checklist. This is a great resource to help you ensure you've completed all the necessary steps prior to launching. If you're looking for feedback on your store before you launch, I also recommend sharing your store link in the Store Feedback discussion board here in the Community Forums (keep in mind that you'll need to provide your storefront password in your post if the store is still protected).

I hope this clears things up, but let me know if you have any further questions. Best of luck with your launch!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

w-works
Excursionist
15 0 10

Thanks, @Julie.  I hope you're right (I thought that it should work if I logged in with the password, but it still did not, so I will have to wait and test once we've launched and troubleshoot it further then, if necessary). 

RainbowKidsB
Visitor
3 0 0

Hi wildworks,

We are having this same issue for over a year. Our sites password is disabled and we still can't post the product image. What solution worked for you in the end ?

Thanks

Peter

 

RainbowKidsB
Visitor
3 0 0

 

Hi support

We have the same issue regarding sharing shopify products to our Facebook group.

Our site password is disabled so Facebook can access information from our Shopify page.

But the same thing happens....our product image is not shared. The name of the product does appear but with an image of our shops logo.

I hope you can help !

 

 

 

george65
Visitor
1 0 0

I have a similar issue. I updates my social sharing image to a photo instead of just my logo. The new photo appears on some platforms (such as Facebook) but not on LinkedIn (if i post the URL the social sharing image still appears as just the logo). How do I update this across the entire web? I already updated the Social Sharing image within my customized theme preferences and the regular website preferences

Julie
Shopify Staff
1109 106 368

Hey, @george65!

Glad to hear that your social sharing image is appearing correctly on most platforms, like Facebook.Are you noticing that the incorrect image is being shared anywhere else? Since this issue seems to be specific to LinkedIn, I took a look at some LinkedIn resources to see how this can be resolved. 

It turns out that LinkedIn offers a Post Inspector, which is similar to Facebook's Sharing Debugger. From there, you can simply enter your site URL and hit the "Inspect" button. The updated share image will then be shown on the preview. Once that's done, I suggest trying to share your URL on LinkedIn again to see if the update took effect. 

If you're still noticing that your logo is appearing rather than the social sharing image you set in Shopify, then this might indicate that LinkedIn is still updating your store's information. In this case, you can follow LinkedIn's instructions on how to customize an image and title when posting a URL on your LinkedIn page. This is a little workaround that should allow you to change the image that appears when you share your URL on an as-needed basis. 

As for updating your image across rest of the web, the image that's shared should be the same one you set in Shopify, but if you are noticing issues with other platforms, let me know!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

BWhitney
Visitor
1 0 0

I am sharing the link to my website on all platforms but the photo I have chosen for my social sharing image does not appear when I post the link. I am using the Simple theme provided for free by Shopify and using the Online Store > Preferences menu to make the change. Any reason why I'm not seeing it. My website is qbartisan.com.

Julie
Shopify Staff
1109 106 368

Hey, @BWhitney!

Thanks for letting me know which theme you're using.

Some themes actually have a social sharing image setting within them, which can be found in Online store > Themes > Customize > Theme settings. If a theme offers this setting, then it will always override any social sharing image settings from Online store > Preferences. The Simple theme offers the ability to add a social sharing image in the theme settings, so you'll just need to add the image there instead. 

I hope this clears things up! Let me know how that goes.

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

RainbowKidsB
Visitor
3 0 0

Hi Julia,

I have the same issue but I can't share images to Facebook. My Shopify shop password is disabled so that's not the problem.

Any help would be greatly appreciated.

Peter.

Rainbow Kids Boutique

Julie
Shopify Staff
1109 106 368

Hey, @RainbowKidsB!

Which theme are you using? Shopify's free themes are designed to display the featured image for a page when you share that particular page link on social media; if you're posting a link to a product page, then the product image should appear as the featured image.

If you're using a third-party theme, then there's a good chance that it is also intended to display the featured image. However, knowing which theme you're using should help determine if this is the case! 

Regardless, it sounds like you may need to use the Facebook Sharing Debugger, which will allow Facebook to access your products' featured images. You can use the Facebook Sharing Debugger with any of your product links. Have you tried this yet? 

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

NickiKirk
Tourist
4 0 1

Hi Julie! I am having the same issue. I cannot seem to get a logo to appear when sharing to social media. I have checked in the preferences and I have my logo uploaded there. I know that if it is a page like "home" where it does not have an associated image, it will use that image. No image shows. I also followed your instructions to go into themes>customize>social media and uploaded my logo there. Still nothing.... I have chatted with shopify customer care and they told me that it was a facebook issue. But it doesn't show in a text message when a link typically does either. I am lost as what to do here and don't want to share my website until I have it correct which is making me loose more potential sales. Please help! My url is levelsdispensary414.com

Julie
Shopify Staff
1109 106 368

Hi, @NickiKirk!

Thanks for reaching out and sharing the steps you've already completed. It sounds like you've added your image correctly on Shopify's end, so at this point, it does sound like this issue is stemming from Facebook directly. 

As mentioned above, the Facebook Sharing Debugger is recommended if you still aren't seeing your social sharing image. Did you get a chance to give that a try? Keep in mind that once you do so, it will take Facebook a few days to update the image on their end. 

It's also worth noting that this issue could also be occurring because you are sharing your store link on Facebook for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

That being said, using the Facebook Sharing Debugger usually solves this type of problem, so I suggest that being your next step. 

Let me know how that goes!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

NickiKirk
Tourist
4 0 1

Yes I had tried the debugger and I tried to share it to my page privately so that facebook could do its "scan." that seemed to do the trick because my logo is now showing! thank God! 

sherrilin93
Visitor
2 0 0

Hi Julie - I still can't get this to work. I've already updated the URL preview image in my Shopify Preferences, however it is still not showing up in Facebook Debugger nor has it changed when I share the store URL. Can you please help me look into it? 

 

My store: www.thedogcitizen.com

Luxier
Visitor
2 0 0

I have also uploaded image & then checked Debugger again it keeps saying Fb: app ID properties missing & required. I did not have this issue with my other store on shopify & it shows up fine. What should i do next?

Rae
Shopify Staff (Retired)
1166 95 361

Hi, @Luxier

My name is Rae, and I work for Shopify. I'm helping out my colleague Julie with this thread and wanted to lend a hand with your questions. 

Can you please send me a screenshot of where you added this image to your theme settings, and how it isn't showing up? That way, I can take a closer look into this. 

In terms of the error you're receiving, this message typically appears when a Facebook app is being used on the store in question. With this in mind, in the 'Apps' section of your Shopify admin, are you currently using any Facebook apps? 

Please keep me posted on this! 

To learn more visit the Shopify Help Center or the Community Blog.

Jazlor
Visitor
1 0 1

Using the debugger worked for me right away. I was experiencing the same issue. Thanks!

21MillionCo
Visitor
2 0 1

Hello, I have been having the same issue. I tried FB Debugger, and it updated the title and the description, but not the photo. Does the photo take longer to update? Or is there something going wrong here? Thanks for your help 

Julie
Shopify Staff
1109 106 368

This is an accepted solution.

Hi @21MillionCo!

Thanks for letting me know that you've already tried using the Facebook Sharing Debugger. When you use the Facebook Sharing Debugger, Facebook will typically update this information immediately. If this isn't happening, then there may be another issue at hand.

To clarify, are you referring to your store logo or a product image? Also, when you share a link, do you see an outdated image or no image at all? 

Generally speaking, the image that appears when you share a link depends on the link itself; if you're sharing a product link, then the image that appears will be your product's featured image. If you're sharing a link to your store's homepage, then the image that appears should be your store logo. If your logo isn't appearing, then this could be a theme-related issue. 

Some themes actually have a social sharing image setting within them, which can be found in Online store > Themes > Customize > Theme settings. Do you see this option there? If so, the image uploaded there will always override the social sharing image you may have added in Online store > Preferences. If your theme does not have this setting, then the image used will be the one you've added in Preferences.

However, if you aren't seeing any image at all when you sharing a link, then this may be because you are sharing that particular link for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

I hope this clears things up, but if you are still experiencing the same issue, please let me know which link you're trying to share, along with the name of the theme you're using. With a bit more information, I'd be happy to do some further digging!

Looking forward to your response. 

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

21MillionCo
Visitor
2 0 1

Hi Julie, thanks for getting back so quickly. I was using the "Debut" theme, and did not realize that the "theme settings" overrides "preferences." I changed the photo there, and it worked! Thanks again

SaberStuff
Tourist
11 0 13

I also am using the Debut theme, and have uploaded a new 'social sharing image' under Online Store > Preferences > Social Sharing Image, and it doesn't work. Every post/link I share on any social media shows my default brand site logo only. Ive also tried the FB debugger to refresh the data catch...but it doesnt change. It just wants to keep pulling my site logo for some reason.

 

EDIT: nevermind. Its working now. Just had to wait about 24 hours to see the refresh

mariambarska
New Member
6 0 0

Hi

 

this is what i am getting when i am sharing my website link. it doesn't matter through text or email or however i share it. no photo is showing. this is absurd

 

please help

 

Screen Shot 2022-02-11 at 10.20.48 AM.png

 

 

Ronny3
Visitor
1 0 0

Hi Julie, 

 

I have been experiencing the same issue. 
I have been sharing the links to my website since I have created it until now. I did not make any changes to the image / logo since I started my website. I have been sharing the link no issues until about a week ago when the images just did not show up when I shared the link. I have tried to find out a solution and reduced the size of the image and I have tried completely changing the image, both still does not work. I mainly share the link on whatsapp but I also use facebook, instagram and other social platforms

 

https://specbodyart.com/

https://specbodyart.com/pages/before-coming-for-a-tattoo-piercing

 

The theme I have been using is 'Minimal' 

Yellow-Web
Shopify Partner
3 0 1

Hi, 

My Website link is, https://www.bubbercouture.com/
When sharing the website link on facebook it is showing another logo which is not used anywhere on the store.

I tried changing the image in Online Store>Preferences and also tried https://developers.facebook.com/tools/debug/ but my issue still persists. The issue is happening only on the homepage. Other pages are showing the proper image.

adeel655
Visitor
2 0 0

Hi, July, thanks for your directions but it is not happening for my store too, not even facebook or any other platform. e.g i am trying to share my store link through whatsapp but it not showing social sharing image even. please advise best. my store link is down below. i am using refresh theme......

https://apparelessence.store/

 

thanks and best regards

adeel655_0-1701500071376.png

 

MahanethraR
Visitor
1 0 0

Hi Julie,

 

I have tried all of the above steps. I am using the highlight theme. Entered all the details in Preferences, when I use face debugger I am getting a "Curl error: 61 (BAD_CONTENT_ENCODING)" error. What can I do in this case. We do not have a facebook page for the brand yet. Please advise on the next steps. 

Thank you.WhatsApp Image 2023-12-18 at 19.49.23.jpeg

thomasfedro
New Member
7 0 0

Having the same issue!! Using social sharing option and still no image. Image parameters are correct. Tried jpg and png and it won't pull it. Refreshed multiple times in debugger. Also doesn't show correctly on  X or Linkden either

Ashlee
Visitor
1 0 0

I have done all of these steps and my logo is still not showing when I post my link in Facebook. I have the debut them on Shopify.

Julie
Shopify Staff
1109 106 368

Hey, @Ashlee!

Thanks for reaching out. 

Just to clarify, did you add your social sharing image in Online store > Themes > Customize > Theme settings > Social media? There, you'll notice a Social sharing image section. This section will always override the social sharing image that you add in Online store > Preferences and this is the case with the Debut theme. 

If you've added your image in your theme settings, then it sounds like Facebook hasn't yet updated the information on their end. If this is the case, then I would recommend waiting a couple of days before attempting to post your store link again.

Another potential reason why you may not be seeing any image when sharing your link could be because you are sharing it on Facebook for the first time. Facebook actually has a help doc on images in link shares that offers further information on why this may be the case. There, they state:

When content is shared for the first time, the Facebook crawler will scrape and cache the metadata from the URL shared. The crawler has to see an image at least once before it can be rendered. This means that the first person who shares a piece of content won't see a rendered image.

In other words, there's a good chance that this is expected behaviour and the next time you share your link, you should see your image. 

I hope this clears things up, but let me know if you are still having issues seeing your image. If you can also include the link that you're attempting to share, that would help. 

Looking forward to your update!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

linkilan
Visitor
2 0 0

Hey, @Julie!

I have studied this topic and can not fix my problem.
I have a theme "Turbo Portland" and in the settings, I have set a banner for share in social networks, but it is not displayed

 

My website - https://justyokoro.com/

Julie
Shopify Staff
1109 106 368

Hey, @linkilan!

I appreciate the fact that you've read through this thread for troubleshooting steps.

If you've added your social sharing image in Online store > Preferences and it's not updating, then this sounds like a theme issue. Because you're using a third-party theme, you'll just need to check in with the theme developers for assistance.

It looks like Out of the Sandbox are the developers of your theme and I managed to find some help documentation outlining how social sharing images work with their themes. You can access that right here. Based on what I'm seeing, it looks like the social sharing image in Online store > Preferences should be the one that's used. They do offer some troubleshooting steps if you are having difficulties seeing the image you've uploaded there, however. 

If you're still experiencing the same issue after following their help doc, then you'll need to contact Out of the Sandbox directly. It looks like they have live chat available through their Help Center, so I suggest reaching out there.

I hope this guides you in the right direction!

Julie | Social Care @ Shopify 
 - Was my reply helpful? Click Like to let me know! 
 - Was your question answered? Mark it as an Accepted Solution
 - To learn more visit the Shopify Help Center or the Shopify Blog

Perice
Shopify Partner
9 0 1

Hey all,

if you want to set and customize the social media image for each product, collection or a page, you can use this app:

https://apps.shopify.com/social-media-share-image

Awesome Store Apps for your Shopify store - https://awesomestoreapps.com/
AlvinColeman3
Tourist
3 0 1

So I updated the image through preferences as well as the theme editor and I am still not getting my image to populate.

 

AlvinColeman3_0-1614875941691.png

 

NickiKirk
Tourist
4 0 1

If you have it loaded in preferences. Next try your themes and make sure there is an image within the theme. Some of the themes have a social sharing image built into them also. Next share your website to your page, privately. Wait 24 hours then see if you share it if the image comes up. Facebook has a "crawler" that reads images for the first time and it needs time to work. Trust me it is frustrating that it doesn't just work, but this is the process.

AlvinColeman3
Tourist
3 0 1

So I just put the image in here today 

AlvinColeman3_0-1614876596627.png

 

But I have had it in here.

 

AlvinColeman3_1-1614876641384.png

 

Now I just have to wait 24 hours and hopefully I should be good?

 

if so thanks!

NickiKirk
Tourist
4 0 1
Click to expand...
Click to expand...
Yes u need to post it to facebook so that facebook can read the website & images. I shared where only I can see it. that gave facebook time to do what it needed to do and within 24 hours it worked.
AlvinColeman3
Tourist
3 0 1

Thank you for the help!

lyynie
Visitor
1 0 1

The Facebook Debugger worked for me! Thanks! Was wrapping my head around where my old logo was still being stored!

Luxier
Visitor
2 0 0

Hi, i read & followed your above guidance as I too, have the same issue. I uploaded the image to my store in Theme settings & it is still not showing..😔