Text on Collection Page Filters block has become invisible

oldlukesy
New Member
10 0 0

Hello guys,

 

The text that would appear on my filters so people can filter by In Stock, Out of Stock has for some reason gone invisible on my collection pages.

 

The functionality and the radio button is still there. Theres just no text.

 

I've tried highlighting the text just incase it had turned white, but it actually appears there is no text at all!

 

Any idea how I can get it back on please?

Replies 12 (12)

ThePrimeWeb
Shopify Partner
1784 502 366

Hey @oldlukesy,

 

Can you share the link to your store? Thanks!

Was I helpful?

Buy me a coffee

🙂

Need help with your store? contact@theprimeweb.com or check out the website
oldlukesy
New Member
10 0 0

Here you go: https://titancards.co.uk/collections/paldean-fates-pokemon-cards-scarlet-violet

This links directly to one of the rogue collections pages with the broken filter text

ThePrimeWeb
Shopify Partner
1784 502 366

Did you change any code? There's an error on the snippet file. I can't really tell because I don't have access to your store's codebase.

 

ThePrimeWeb_0-1709837443356.png

 

Was I helpful?

Buy me a coffee

🙂

Need help with your store? contact@theprimeweb.com or check out the website
oldlukesy
New Member
10 0 0

I stay away from code, I haven't even added custom CSS or anything.

It was working, went afk. Came back and it wasnt!

 

I see these errors, looks like it cant find something:-

faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
8ProductGridItem.js:206 Quick buy: invalid QuickBuy data found. Unexpected end of JSON input
_initQuickBuy @ ProductGridItem.js:206
faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
faceted-filter-group%20line%20105):%20invalid%20url%20input:1


Failed to load resource: the server responded with a status of 404 ()
theme.css:1


GET https://titancards.co.uk/cdn/shop/t/5/assets/Liquid%20error%20(snippets/faceted-filter-group%20line%... 404 (Not Found)

ThePrimeWeb
Shopify Partner
1784 502 366

The URL that has been passed is https://titancards.co.uk/cdn/shop/t/5/assets/Liquid%20error%20(snippets/faceted-filter-group%20line%20105):%20invalid%20url%20input

 

The last bit highlighted in red is the error, so obviously that link does not exist.

 

 

Can you check if the swatches images still exist? If not upload them or disable swatch images and try. The error is because it can't locate the swatch image file.

Was I helpful?

Buy me a coffee

🙂

Need help with your store? contact@theprimeweb.com or check out the website
oldlukesy
New Member
10 0 0

This will probably sound a little ridiculous but I'm new to shopify and literally have no idea where to access the swatches images? I've just had a look through on the customise collections > default collection page where the filter block is located but I can't see anything about image swatches?

ThePrimeWeb
Shopify Partner
1784 502 366

Hey @oldlukesy,

 

Can you switch over to Tag filtering?

 

ThePrimeWeb_0-1709861625135.png

 

Was I helpful?

Buy me a coffee

🙂

Need help with your store? contact@theprimeweb.com or check out the website
oldlukesy
New Member
10 0 0

Done, that version isnt ideal for my store but it does work (as in the options show up at the side properly)

oldlukesy
New Member
10 0 0

So I am using Empire Theme.

I managed to go to theme settings > default collections > select products > untick enable color swatches (none of my products use a colour tag, I only have in stock/out of stock and price as filters)

I disabled enable color swatches but sadly still didn't change anything

oldlukesy
New Member
10 0 0

Don't suppose anyone can assist with this? 

ThePrimeWeb
Shopify Partner
1784 502 366

Can you check if you need to set it up here. Unfortunately I cannot test this fully because it's a paid theme and I don't have it. I can run as a trial but I cannot publish it and this Filters option requires me to publish the theme.

ThePrimeWeb_0-1710167789366.png

 

Was I helpful?

Buy me a coffee

🙂

Need help with your store? contact@theprimeweb.com or check out the website
oldlukesy
New Member
10 0 0

Hey @ThePrimeWeb thanks for trying to assist with this

FYI I found out what it was. I use empire, a paid theme and they have admitted to a randomly occuring bug which has since been fixed. I'm now just looking at having them apply that to fix mine. So it actually genuinely wasnt something I'd done, to my relief Lol