Venture Theme - How to add a video that's going to auto play?

Solved
SYegor
Excursionist
36 1 5

Hi,

 

I'm trying to add a video to my home page but it won't auto play without me pressing the play button. How do I make it auto play? Thanks.

Accepted Solution (1)

Accepted Solutions
SYegor
Excursionist
36 1 5

This is an accepted solution.

I have figured it out... for those of you that might run into this issue. Here's how I did it, and it will work with most themes.

 

You need to add section, custom HTML and use the code below

 

<p><video muted="muted" autoplay="autoplay" loop="loop" playsinline="" width="80%">
<source src="VIDEO URL">
</video></p>

 

If you don't want your video muted, use the code below

 

<p><video autoplay="autoplay" loop="loop" playsinline="" width="80%">
<source src="VIDEO URL">
</video></p>

 

Upload the video to shopify files and place the link in VIDEO URL above.

View solution in original post

Replies 4 (4)
SYegor
Excursionist
36 1 5
Ninthony
Shopify Partner
2247 339 901

What is your store url and what theme are you using? If we need a password to get in please post the password.

If my solution helped you, please like it and accept it as the solution!
If you'd like to make any edits to your store, please send me a personal message and we can discuss what you'd like to accomplish :D
SYegor
Excursionist
36 1 5

This is an accepted solution.

I have figured it out... for those of you that might run into this issue. Here's how I did it, and it will work with most themes.

 

You need to add section, custom HTML and use the code below

 

<p><video muted="muted" autoplay="autoplay" loop="loop" playsinline="" width="80%">
<source src="VIDEO URL">
</video></p>

 

If you don't want your video muted, use the code below

 

<p><video autoplay="autoplay" loop="loop" playsinline="" width="80%">
<source src="VIDEO URL">
</video></p>

 

Upload the video to shopify files and place the link in VIDEO URL above.

View solution in original post

kbyrd
New Member
1 0 0

This works within the Shopify admin, but doesn't seem to work on mobile or even desktop outside of the admin. Anyone else having this issue?